Installing in Eclipse

Installing Eclipse and Plug-Ins

You need to install the following to use Vaadin Designer:

  1. Eclipse as described in "Installing Eclipse IDE"

  2. Vaadin Designer from vaadin.com/eclipse

Optionally you can also install Vaadin Plug-in for Eclipse as described in "Installing Vaadin Plugin for Eclipse".

Vaadin Designer is compatible with Eclipse Mars and later, available from www.eclipse.org/downloads. We recommend choosing the newest version of Eclipse IDE for Java EE Developers.

Vaadin Designer can be installed together with the Vaadin Plug-in for Eclipse, from the same Eclipse update-site. In Eclipse, go to Help  Install New Software, press Add…​, enter Vaadin as name and http://vaadin.com/eclipse as location.

If you already have the Vaadin plug-in installed, just choose the Vaadin update site. Make sure the whole Vaadin category is selected (or at least Vaadin Designer), then click Next to review licensing information and finalize the install. Please restart Eclipse when prompted.

Once installed, Vaadin Designer can be kept up-to-date by periodically running Help  Check for Updates.

Uninstalling

Follow these steps if you want to remove Vaadin Designer from your Eclipse installation:

  1. Go to About Eclipse.

  2. Click Installation Details

  3. Select Vaadin Designer from the list.

  4. Click Uninstall…​