XULRunner on x64 Windows 7

It appears as though the 32-bit version of XULRunner won’t run on a 64-bit version of Eclipse and Java. Is that true? I am using the SpringSource Tool Suite which is 64-bit. I also have a 64-bit Java JDK installed.

Is there any way to get the Vaadin GUI up and running on this sort of setup?



It seems you would need a 64 bit XULRunner which is not available because Mozilla does not make 64 bit builds (yet).
But the editor should though work pretty well nowadays even without XULRunner. There will be an error popup when you try to edit a file for the first time but it will then fall back to using the internal browser (IE). IE is a bit slower but should work just fine.

The best solution would be that Eclipse (or we somehow) could provide an embedded WebKit based browser so the editor would be fast and it would be easier to get started. We do have a ticket about this (#4603) but there has not been much progress lately.

Unfortunately, I still get the error, but indicates:

“Could not open design view”

On the Vaadin java file, I right click and say “Open with” → “Vaadin Editor”. The message about xulrunner comes up, but when I click on the “Design” tab, it gives me other message.

I’ve gone to “Window”->“Web Browser” and explicitly selected IE, but that doesn’t work either.

I’m using SpringSource Tool Suite version 2.5.2.RELEASE (based on Eclipse 3.6.1)

Thanks for your help and any other suggestions you might have.

I have the same problem. Any Idea???

Unfortunately, that error message does not have almost any information about what really went wrong, so it could be anything from not being able to parse the file (most probable reason by far) to not being able to open a browser to some internal error.

On which file are you trying to open the Visual Designer (Design tab)? Have you been able to open the same file with the visual editor before this?

The editor requires a specific structure from the file you are trying to open, and when you create such a file with the Vaadin plugin, it should be automatically opened (and associated) with the correct editor, but this might not be the case e.g. for files checked out of version control or generated by Roo.

If using the Vaadin Roo add-on to create the files, note that currently only the entity forms generated with the correct (visuallyComposable) option can be used with the visual designer, and may require the latest version of the visual designer Eclipse plugin from the “experimental” update site (see below).

If you have not tried it yet, create a new file just generated with “New” → “Vaadin Composite” and see if you can get to the design tab. If that does not work, try to upgrade to the latest development versions of the Eclipse plugins using the update site http://vaadin.com/eclipse/experimental - even if it does not solve the problem, it might log slightly more information about it depending on what kind of an issue it is.

Hi all!

No one can help us to use Vaadin Visual editor with Eclipse Indigo on a x64 Windows 7 platform???

The pop-up message state that “Could not start XULRunner …”

Thank you in advance!

Ivano C.

Any news on this issue? I tried a 64 bit version of Xulrunner , but it still did not work. This is my configuration

Java™ SE Runtime Environment (build 1.6.0_31-b05) x64
Eclipse Java EE IDE for Web Developers. Version: Indigo Service Release 1, Build id: 20110916-0149 x64
Vaadin Plug-in for Eclipse
Mozilla XULRunner 1.9a1_00000000000 x64

As workaround I installed the 32 bit version of Java & Eclipse, but this cannot be the final solution. :frowning:

Follow the steps:

  1. Open Eclipse
  2. File > New > Project > Vaadin > Vaadin Project
  3. Name: “myproject”
  4. Runtime: Apache Tomcat 7.0
  5. Config: Vaadin, java 6, Servelt 2.4
  6. Deployment: Servlet (default)
  7. Vaadin version: 6.7.5
  8. Once ready, expand your com.example.myproject package.
  9. Click on you r MyprojectApplication.java file and Run On Server [ Alt, Shift, X, R ]
  10. If the “Hello Vaadin User!” app runs in your internal browser you’re good. If not, you’ll have to get the SWT kit installed to add this functionality.
  11. Once we know everything works, Right click your MyprojectApplication,java file and go to
    New > Other > Vaadin > Vaadin Composite > name it MyComponent > Finish
  12. You will get “Could not start XULRunner” error because XULRunner is not installed, because it sucks.
  13. Click OK
  14. Your new Component should open up into Source view
  15. Click [Design]
    lower-left corner of editor view, and you’ll be dropped into Visual Editor mode regardless.

*Only reason this won’t work is if you don’t have internal browser functionality in Eclipse yet, or are using an incompatible Eclipse+Vaadin environment.

==================MY SETUP=====================
No XULrunner installed
Eclipse Java EE IDE for Web Developers.
Version: Indigo Service Release 2
Build id: 20120216-1857
Windows 7 Home Basic (64-bit)
Intel Atom D510 @1.66GHz
2.00 Gb Ram

I know this is an old issue, but it still exists. Is it possible to have you (Vaadin developers) change the Eclipse plug-in to only show the error pop-up once per session or not all. Or provide a check box on the pop-up that says “Do not show me this warning again”. The pop-up is extremely annoying.

create an enhancement request
about this. A “do not show this warning again” option should be relatively easy to add.

The real solution would be to use a WebKit instance embedded in Eclipse (or JRE), but we (and many others) have been waiting for that to come to Eclipse for some years now. The latest Eclipse can at least use some WebKit based browsers if installed separately on the computer.

Done. http://dev.vaadin.com/ticket/10059. I concur that this popup is extremely frustrating and annoying.

Please, please, please (with sugar on top) finally fix this bug after years of complaining! IMHO it’s a bug and not an enhancement request because common usability rules are violated. If a problem (here: XULRunner can not be started) automatically leads to an acceptable fall-back behaviour (here: IE will be used) then the only consequence for the user is some (potential) performance degradation. Nobody would consider that a fatal error. This should clearly be flagged as a warning in the error log but not interrupt the user more than at most once. Especially because you seem to know well that for Windows 64bit users there is just no other solution to the original problem.

To make the problem with the error popup worse, it can happen already early during the startup of Eclipse if your last session left a designer editor open. Then this unfortunate dialog pops up somewhere, possibly behind other windows, and has no caption in the task bar. It’s just not visible and it holds Eclipse from bringing up the rest of the UI. That’s bad, bad, bad ;-(

And so easy to fix…

It seems it is Eclipse SWT dependency,



Attempt to detect an OS-registered XULRunner with version or newer (in order to enable JavaXPCOM use). Note that only XULRunner installations that are compiled for the same architecture as the running SWT will be considered.
Attempt to detect an OS-registered XULRunner with a version earlier than (again, the architecture must match that of SWT).

So… try to use 32-bit Eclipse instead…

If installing 32-bit Eclipse is the only possibility for now, why doesn’t the documentation mention that? It does not even mention that a XULRunner must be installed even on 32-bit Eclipse for the VisualEditor to run.
Please update the documentation.

Does anyone at Vaadin understand how stupid this on going issue make Vaadin look? The problem still happens (I know as I’m trying to fix it at the moment).

The wonderful Vaadin + Eclipse page at https://vaadin.com/eclipse needs to cover this issue with details. Otherwise quick evaulations turn into reports that things do not work as documented. Trying to resolve the issue then finds threads like this one that indicate that the problem has been on going for 3+ years - again more bad marks.

refer https://vaadin.com/forum#!/thread/29139/4737420

thx, it worked for me!

I got the problem that after i had finished installed the vaadin plugin for eclipse,the design view in vaadin editor wasn’t available,it disappeared,there was just the source view.

then ,followed this guide
downloaded the XULRunner
and installed it

then added the follow to the eclipse.ini in the eclipse home directory and restart eclipse
-Dorg.eclipse.swt.browser.XULRunnerPath=C:\Program Files (x86)\Mozilla XULRunner(the path I extracted XULRunner)

It works.Although,it showed some error message when restarted eclipse ,it was about that XULRunner can’t be found.Just ignore it,and start the eclipse.

My system enviroment:
eclipse kepler
jdk1.7.0_55 x64
win7 X64
XULRunner en_US_for_win32

hi All,
I m new to Vaadin community, tried to download it on my eclipse and found strange errors while creating a simple base project.
I m using windows 64 bit, eclipse kepler, java7 and Vaadin 7 project
Tried with servlet webmodule 3.0 and 2.5 configs, but no use.

Do i need to switch to IntelliJ or Netbeans ? suggest me please.