Vaadin Designer now available from Labs

I’m bringing some awesome news, everyone:

Vaadin Designer is available
Vaadin Labs
, starting
right now!

It’s an early version of the next generation Vaadin WYSIWYG tool, so go get it, try it, and report back!

We have an awesome team working on this, and in order to make the Designer into the best tool we can during the coming weeks and months, I really want to hear your thoughts and ideas - here in this thread or tweet
. Or better yet, join me live at

Get it.
Try it. Report back!
Thank You!

// Marc


Make sure you
use Eclipse Luna and Vaadin 7.4
(beta) for your project.

Great News,
best news ever for ( 2015 ).
i’m going to try it just right now !


first to mention: You need vaadin 7.4+ to use this designer.

So I updated me project to 7.4.0.beta1 and I can choose src, package, name and template “Blank”. But the “Finish” button has no function. Nothing happens.
I am using eclipse version: Juno Service Release 2

Please try using Eclipse Luna.
The site should mention this requirement, I’ll make sure this get’s stated clearly!

Note that Luna SR1 needs a hotfix (not related to Vaadin Desinger but w/o the hotfix all kinds of things bug), check
for more details.

Also, if you encounter problems, enable the “Error Log” view (Window->Show View) - it might contain additional information that can help us figure out the cause.

Best Regards,


I have the same problem as Wolfgang. FInish button doesn’t work.
I’m using Eclipse Luna SR1 with hotfix.

You can see stacktrace from error log in attachment.
I also included elipse version and list of installed plugins.
17735.txt (6.84 KB)

nice work !

i just downloaded Vaadin Designer .

& Looked Great ! Thank You Vaadin … that is what i’m looking for.

#1 the best thing i found with these new relese is the real WSIWG. so i can build my Components without compiling the source code.
#2: i can choose any root Layout as i like.

#some issues :

i-  think there is some delay after I droped any component.
ii- when i create new Vaadin Design, and the desig opend the grid looks too small so i have to resize
    resize it, i think it's better if open with somthing like 800x600 . or provide a configration for these greate tool.
iii- i checked the generated code and i want ask some questions:
     1# every generated component marked as a public is that mean i must use MVP and create seprate presinter
     to manage my events ?
     2# Design class looked like read the components from html file and parse it to vaadin -> is that mean i can manage my components throght
     html ?

Thank You Vaadin


Oh man, Mohammed is making me jealous :>

I installed newest eclipse version and also installed the hotfix. But I still have the same issue like mmat (NPE at com.vaadin.designer.eclipse.wizards.NewDesignWizardPage.getSelectedTemplateInputStream(

I tried it again with clean eclipse installation.
With the same issue.

I’m using windows7 64bit
My session data from error log:

java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=cs_CZ
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

Tue Jan 13 20:32:20 CET 2015
Unhandled event loop exception

If you want to test out Vaadin Designer for portlet development in Liferay, you will want to set the following in your file…


Vaadin Designer requires Vaadin version 7.4.0.beta1 which seems to have the following defect…

Setting the above property resolves the issue.

I also get the same exception when pressing finish.

    at com.vaadin.designer.eclipse.wizards.NewDesignWizardPage.getSelectedTemplateInputStream(
    at com.vaadin.designer.eclipse.wizards.NewDesignWizardPage.createJavaFile(
    at com.vaadin.designer.eclipse.wizards.NewDesignWizard.performFinish(
    at org.eclipse.jface.wizard.WizardDialog.finishPressed(

Here is my environment…

java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.jee.product -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product -data C:\dev\SuiteLife\workspace\trunk -product org.eclipse.epp.package.jee.product

I asked this on the blog page, but did not see an answer:

Will this tool (or, hopefully, the future Netbeans variant) be able to be used to create Liferay Portlets using Vaadin?

keep up the good work!


Hi !

did you try clean Ivy Cahches and create new Project as a Vaadin v7.4 ()->{ run test to be sure everything is going right }
and create your new design [ you can also push the button resolveAll → to resolve your Ivy debencies]

look this informations if they can help you:

My Device Info:
OS   : ArchLinux 86x [ manjaro distribu ]

Ram  : 2G.
Proccessor: 86x.
Eclipse Standard/SDK
Version: Luna Service Release 1 (4.4.1)
Build id: 20140925-1800
WTP bundle:     3.6.1.v201409111852
Vaadin plug-in for eclipse:
Installed Vaadin Versions
|  |_Vaadin v7.3.8
|  |_Vaadin v7.4
|  |_ Vaadin v7.3.8
|  |_ Vaadin v7.4

wish if i can help you more.

Thanks everybody for the feedback, really nice to see you like the idea of a new designer! :slight_smile:

We (designer dev team) are currently looking into why the NewDesignWizard isn’t opening for some of you, it appears to be an issue on some Windows machines where the design templates aren’t found. I’ll keep you posted on that fix.

Regarding portlet support we currently have no plans. That doesn’t mean we will not support that in the future as well, but the main focus currently is to get the designer to work awesomely with the traditional webapps first.

Regarding other IDE support, currently we are solely focusing on Eclipse but there has been some mentions of other IDE’s on the horizon as well. We’ll see :wink:

To clarify the Portlet support:

It depends on what you mean; as I mentioned, the format that the Designer produces is supported in Vaadin 7.4 (you can even use the declarative format w/o the Designer as well), so basically if you can use Vaadin 7.4 in your project, you can use the Designer to design the UI.

We do not have any portlet-specific features in the Designer, though, but it might be prove quite useful in any case - for instance, you could add size presets for the various portlet sizes your portal uses, so that you can quickly design for a specific size (we actually discussed adding some portlet size preset by default, but did not since there are no ‘standard’ sizes).

Please let us know if you have ideas or suggestions how we could support portlet design better!

// Marc

I see I am facing a similar problem that others are facing. I have tried to analyze why and now I have some questions to them who are successfully running this addon:

  1. Package name: what is the correct convention to be used here, should I just use the project name or the package path e.g. com.myvaadin.testproj1 (please see the snapshot of my project in the attached photograp vaadinDesigner1.png)

  2. Vaadin designer server setting: You will see an issue indicator in javaResources in the attached pic1, when I right click on janaResources and select properties option, I get a error, saying “the currently displayed page contains invalid values” and when I click ok, popup window for vaadin designer properties displayed where server setting indicates I have to enter server and port. Please see the 2nd picture (vaadinDesigner2.png). Question is what is the right server definition I should use.

Eclipse Luna, Java8, tomcat 8, windows 7, vaadin 7.4beta

Thanks for any tips.




For the first issue at least, just a quick fix, until we actually fix it :slight_smile: please right click in Project Explorer on the package where you want to save the design file → New → Other → Vaadin Design (or just select the package in Project Explorer and press the CTRL+N shortcut, etc.). Then in the New Design form just fill in the file name, don’t change the package or the source paths.

Thanks for the feedback,

With the latest updates, the Finish button now creates something and I get a java and an html file. However, I get some errors and am unable to proceed. It defaults to the Design view of the html file and displays the message “Changing theme, please wait…”. The message does not go away. The error view shows the 2 errors that were generated…

Switching to BlockingIO


Failed to create comet support class: class org.atmosphere.container.JettyServlet30AsyncSupportWithWebSocket, error: null

Hi Gordon,

Can you please tell us your OS type/version and send us the full .log file of the workspace when this happen (preferably remove .log file before starting eclipse so we get a small one :slight_smile: ). We had issues like this with different behaviour on each OS, but right now we can’t reproduce it on any of the ones we’re testing.

Can you also try to press “Preview” and then press “Edit” again on the editor toolbar. Does this brings the editor to live?

Thank you,


I am using Windows 7 Professional (64 bit). Here is some additional environment info…

java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

Attached is my eclipse .log file.

So presssing “Preview” and then “Edit” removes the “Changing theme, please wait…” message. But now I get an animated loading icon that does not go away. (2.33 KB)

Hi Gordon,

Thank you for your details. We are able to reproduce it only on Windows 7, unfortunatelly or is it fortunatelly. I’ll let you know as soon as we have a fix.

All the best,