Problem installing Eclipse Vaadin Plugin


I’ve installed Vaadin Plugin to this computer using the instructions from , and the installation itself seems to work just fine. However, when I’m creating a new Vaadin 7 Project and press Finish, the configuration menu doesn’t disappear and it doesn’t include Vaadin.jar and some other files in the project. This is how my project setup looks like when I press Finish:

After Finish, it creates the project partially, and the New Vaadin 7 Project -menu doesn’t disappear

This is how the project looks like (no vaadin.jar included):

This is how it is supposed to look like I think:

I’ve tried with different versions of Eclipse, different JRE:s, installing through the marketplace and directly through “Install new software…”, having Tomcat as Target runtime (and without) and none of those seem to work.

Any tips how trying to solve this issue? Currently I’m using Windows 8, but I guess I’m trying with Ubuntu next if it would help. Thanks for any answers, help is appreciated :slight_smile:

I have exactly same issue, can anyone give a clue how to resolve this?
I also have Windows 8, maybe this is a problem

Me too facing this problem. I tried in ubuntu too but the same problem prevails .
Anyone know the solution for this issue?


Hi guys,

This post
may help you.