Visual designer not working (again)

I have red tons of threads about this issue but none of the solved my problem.
I’m using eclipse mars, installed ivyde and tomcat 8. When I open the vaadin editor it doesn’t appear design tab.

Installing Xulrunner as suggested by many threads, not succeeded.

Is there any advice?
Thank you so much


I can second the call for help here.

In my case, I am running Eclipse LUNA SR2, JDK 1.8, Win 7, installed the apache Ivy plug-ins.

Also I have tried the default update site, the experimental update site or the market place version of the vaadin plug-in.

I do not even get source code showing up in the vaadin editor.

I have also tried addin the patch which was suggested for LUNA SR1, but I am still out of luck. We are moving to using LUNA and I have a Vaadin Project with some composites that were designed in the visual editor and I cannot work on them at the moment.

Any help would be highly welcome.

Thank you,

P.S.: Installed plugins:
​ Apache Ivy 2.4.0.final_20141213170938 Apache Software Foundation
Apache Ivy Ant Tasks 2.4.0.final_20141213170938 Apache Software Foundation
Apache IvyDE Apache Software Foundation
Apache IvyDE Resolve Visualizer Apache Software Foundation
Eclipse IDE for Java EE Developers epp.package.jee null
Vaadin Plug-in for Eclipse Vaadin Ltd
Vaadin Visual Designer for Eclipse (upgrade only) Vaadin Ltd


I did another setup, this time with Eclipse mars M5. The Source Editor is showing, thw visual editor is not.

The configuration is listed below.


Again, the visual editor is missing and there is no name displayed in the vaadin editor tab,.
Apache Ivy 2.4.0.final_20141213170938 Apache Software Foundation
Apache Ivy Ant Tasks 2.4.0.final_20141213170938 Apache Software Foundation
Apache IvyDE Apache Software Foundation
Eclipse IDE for Java EE Developers epp.package.jee null
Vaadin Plug-in for Eclipse Vaadin Ltd

I finally manually installed XULRunner in my development environment, downloading it from:

After unzippung the file, I added to eclipse.ini (adjust path to your actual install path):


So to make this even more confusing, I then went with the recomendation I found elsewhere and pointed the path above to (without adding xulrunner to my system path):


And actually this works just as fine.

So overall, the behaviour is pretty strange and the documentation on for the plug-in installation is inconsistent.

Here the requirements for Apache Ivy are documented:

Here, the Ivy dependency is not mentioned, and actually it appears, that it is not required for the editor (having the eclpise EE package installed):

Nowhere the in the documentation the XULRunner issue is documented. I would suggest to synchronize the documentation here.

Hope this helps.

Best regards,

Hi Dominic,

it is very strange to that we are the only ones who are stuggling with this issue.

Anyway, have you got any clue?
Someoune told me it is not necessary install IvyDE plugin provided it is integrated in Luna.
The only necessary tools seem to be: java 8, Tomcat (8 in my case), Eclipse Luna and Vaadin. Do you agree? Does it need something else?

Beside this, even though not requested in vaadin installing instructions, following this (and many others) clue;!/thread/29139/2499444
I installed XULrunner in dir D./xulrunner then I copied this statement at the bottom of eclipse.ini


Obiviously that hadn’t be effective.
Hoping it might be someway useful

The only things needed for me to get it running:

a) Add "-Dorg.eclipse.swt.browser.XULRunnerPath=C:" to the eclipse.ini. I did not have to install an actual xulrunner manually!
b) I did not install the Ivy dependencies (currently using Luna SR2 EE package)
c) Install the vaadin plug-in from the maketplace

I still get the annoying warning about xulrunner startup, but it works.


Oh also I am teaching a class and most of the students had problems with the visual editor and getting it running.


Unfortunately it doesn’t work with me.

Let you make me summarize MY enviroment:

Java 8, Tomcat 8 (they don’t seem to be involved), Eclipse EE Luna, then via marketplace I installed Vaadin and finalliy I modified this way eclipse.ini

-startup plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

Can you tell me how is arranged your environment?

Thank you so much

eclipse.ini had been modified THIS way

-startup plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar


Anyway you say “most” of your students, not “all”… It seems this shows a certain kind of randomness…

I really cannot say much more. And “most students” only implies that there were only a few who bothered with the topic, as not all have to deal with this issue and don’t care.


Ok… but can you tell me what actually is your environment?
Is it:
Luna EE
Vaadin via marketplace
NO XULRunner installed
as the last row in eclipse.inii?

That is exactly the environment.

I also have maven installed, and a few other plug-ins, but I added them after veifying the vaadin plug-in functionality.

Currently it is java 1.8.0_25 (need to update)
Eclipse Luna SR2

And the following plug-ins (the others are SVN and maven integration stuff):
CollabNet Merge Client 3.0.13 CollabNet
Eclipse IDE for Java EE Developers epp.package.jee null
JNA Library 3.4.0.t20120117_1605 null
m2e connector for build-helper-maven-plugin Sonatype, Inc.
Maven SCM handler for Subclipse Sonatype, Inc.
Subclipse (Required) 1.8.22
Subclipse Integration for Mylyn 3.x (Optional) 3.0.0
Subversion Client Adapter (Required) 1.8.6
Subversion JavaHL Native Library Adapter 1.7.10
Subversion Revision Graph 1.1.1
SVNKit Client Adapter (Not required)
SVNKit Library 1.7.9.r9659_v20130411_2103 TMate Software
Vaadin Plug-in for Eclipse Vaadin Ltd

Have you verified, that you are actually using the JDK you want to use under Preferences->Java->InstalledJREs ? I have not seen this to be related to the issue at hand but maybe …


Thank you so much for your kindness.
I have to ask you three more questions:

  1. Is your OS a Window’s version?
  2. did you installed somewhere XULRunner?
  3. did you add
    as the last row in eclipse.inii?

Thanks in advance

  1. Win 7 64bit
  2. Initially yes. But I deleted the install again.
  3. yes.


Well, so do you have any idea about the reason of the failure of my installation that seems totally equals to yours? Could be something related to browser? (or anything else)

Hi All,
So far i never been able to run Visual designer in eclipse Luna, tried couple of times, Luna SR2 java8 and vaadin 7.4.1 eclipse kepler is working fine. Visual designer is loading both tabs but nothing is working on designer tab, ex: if i drag and drop the file won’t change and designer tree won’t update. The designer tree view also showing only the first absolute layout but there are lot of layouts in the file. however these java files were coded in kepler.


I am failing to trial Designer on an 8G 64bit workstation running Ubuntu.
I’ve installed eclipse and the vaadin plugin and designer from scratch twice.

It will run and create a new project in which I can use the designer, but restarting eclipse leaves me with the
“Please wait, loading view …” for the designer indefinitely.

The preview still works and then it hangs and crashes eclipse every time.
I hope somone has simple explanation for this?

For me,
export SWT_GTK3=0

…seems to have fixed my issue. Thanks Patrik in CS.