Update Vaadin from 7.4 to 7.4.2

I’ve updated vaadin from 7.4 to 7.4.2. To do so, I’ve opened my ivy.xml file and changed to . After waiting some time, everything seems okay.

When deploying my webapp, I’ve opened it with ?debug parameter, and I’ve been able to see the following (see update.png): Client engine version: 7.4.0, Server engine version: 7.4.2 and Theme version: 7.4.2.

Should not Client engine version be on 7.4.2? Have I done something wrong?


You haven’t compiled the widget set.

Ivy sometimes causes trouble in Eclipse, and some of the following may help:

  • Right mouse button on project → Ivy → Reload settings
  • Right mouse button on project → Ivy → Refresh
  • Compile widget set(s) and themes with the buttons in Eclipse toolbar (or with a build script)
  • If with build script, remember to refresh Eclipse project with F5 (good to hit that button anyhow if there’s any problem)

  • Refresh server
  • Stop server
  • Right click → Clean Tomcat Work Directory
  • Right click → Clean
  • Restart server

  • If the above doesn’t help, could also do “Ivy → Clean every repository cache” first, but that takes quite a long time and should not be needed.

I’m gonna try it now.

Thank you! I followed your steps and it did the trick :).

Thanks Marko, worked for me too !

The above steps, made my server and client version agree. But my Theme version is still 7.2.4, how do I correct that?
Thank you

Nevermind, the issue was resolved. Just had to refresh somethings.
Thank you


I switched from Ivy to Maven several months ago and now I’m facing the same issue. However, I’m not able to update the widgetset…

How can I recompile the widgetset in Maven? I don’t care if it can be done either in eclipse or via CLI.


I’ve been able to compile the new version of the widgetset doing the following (note that I use Maven’s standard directory layout):

  1. Remove “widgetset” folder located at “/src/webapp/VAADIN”
  2. Compile the widgetset via Maven:
  3. mvn clean vaadin:compile


I tried recompiling and also removing the widgetset folder and recompiling and the problem persisted.
I’m using Ivy and it stores old versions of every JAR in C:\Users<myusername>.ivy2\cache\com.vaadin\ and subdirectories. And Vaadin client compiler was choosing one of the old JARs when running. As I don’t know how to change the Vaadin client compiler commandline, I just removed the old JARs and left only the latest one, and recompiled.

BTW this is a related thread: https://vaadin.com/forum#!/thread/11725516