Could not start XULRunner (version 1.9 or higher required)

Trying to run the latest Vaadin as per the example on
on windows, always throws the message from wysiwyg/eclipse-plugin/src/com/vaadin/wysiwyg/eclipse/editors/ Is it not meant to work on windows?
XULRunner 1.9 downloaded and installed as per instructions.

Editor opens, doesnt display the same as the example, bottom pane just shows all white but its possible to select something in there as when you click on the list it then selects whatever is there for example a text field.
Pictures available but no place to upload it to.

You can upload images to forums in the following way

  1. Click Settings from the top of the screen
  2. Select Image Gallery
  3. Change “Content for” to “My Community”
  4. Add a folder. For example forum-images
  5. upload image
  6. View image and copy image URL
  7. Add image to this forum by clicking image button and entering the above mentioned url

Excellent, thanks managed that, picture now in post.

The “Visual Editor” should work perfectly well on Windows, once XULRunner is installed properly - note that it’s still ‘experimental’, and there will almost certainly be some issues…
We hope to remove the manual XULRunner install requirement as soon as possible.

Some quick checks:

  • Which Eclipse version are you using?
  • Did you restart Eclipse after installing XULRunner?
  • Do you have multiple versions of XULRunner installed? Maybe we’re not doing it right if there are several XULRunner versions available.

Sorry, I’m just guessing - I’m on Linux myself, will have to try reproducing your problem on a windows box. Only our ‘windows guys’ have tested the Visual Editor on Windows yet (not nearly enough testing done yet, hence ‘experimental’).

Best Regards,

Eclipse Version: 3.4.1
Build id: M20080911-1700

XUL Runner looks properly installed to me, although I am still surfing around to find out if there is some definitive way of finding out the versions installed, I only find 1.9 in the Registry.

Eclipse and machine restarted.

The editor seems to be working, you just see that the bottom right side doesnt show the widgets available such as Label etc as the text is in white (I am guessing here :slight_smile: ), you can mouse over the panel with the button held down and it shows the widgets and when you release the button they are added, so its just the visibility of them.
Also I dont know if the list is complete as there is no tabsheet for example.


Just tested the editor using IE8 and indeed the bottom right select is white so it does seem there is a problem with your XULRunner installation and your Eclipse uses IE. If you get the popup message about “Could not start XULRunner” it means that NO XULRunner could be found. The version of XULRunner is not checked in any way if I remember correctly.

I just added a fix for the white on white so the editor might be usable in IE now too. Note however that it has not been tested with IE and you might run into weird issues. Also, as usual, IE is slower than XULRunner.

Hi, I have the same message when Eclipse startup.

I got XULRunner 1.9.14 from Mozilla web site and I run ‘XULRunner.exe –register-global’.
Is this command to let Eclipse see XULRunner?

Thanks in advance, Matteo

Hi there:

I have installed Eclipse Ganymede in Windows 7 machine, and i have the same error.

Just Install xulrunner from the sourceforge.

It’s works for me.



Thanks for the installer link. It worked for me also.

Same as that got the installer from the link thanks a million Jorge

does not work for me. Vaadin Editor can’t be open.
I have
Windows 7 64 bit,
Eclipse 3.7 for J2EE developers
last Vaadin plugin installed

I installed XulRunner using the link above, then even executed “xulrunner.exe --register-global”, restarted the machine - nothing helps. Eclipse keeps complaining that could not start XULRunner.

this error message is shown every time I try to open a Vaadin file with “Open with… Vaadin Editor”.

then I’m trying to switch to “Design” tab, and it says
“Could not open design view:
Failed to find or parse visually editable class
caused by
Not an editable CustomComponent”

I only have a default Vaadin project sample without any custom components, so I expected the sample Application class to be properly parsed:

package com.example.vaadin1;

import com.vaadin.Application;
import com.vaadin.ui.*;

public class Vaadin1Application extends Application {
public void init() {
Window mainWindow = new Window(“Vaadin1 Application”);
Label label = new Label(“Hello Vaadin user”);


No - only subclasses of CustomComponent that have a specific structure can be edited using the visual editor. See e.g.
this book chapter
. In such classes, you should not manually modify any parts that have the @AutoGenerated annotation.

To create a CustomComponent that you can edit using the visual editor, use “New… → Vaadin CustomComponent (composite)”. You can then add it as the only component to your application if you want to use it as a top-level view.

I see, thanks.

Same issue here on my work desktop.

I guess it has got something to do with a) a 64 bit Eclipse b) Eclipse running in a 64 bit JVM… as I already managed to fix the issue on my laptop.

All tips more than welcome, will also come back here when I’ve managed to solve the issue.


Have you tried out the instructions at
(Just Ignore the Aptana related stuff) ?

Yes, I tried but nothing…

No one can help us to use Vaadin Visual editor with Eclipse Indigo on a x64 Windows 7 platform???

The pop-up message state that “Could not start XULRunner …”

Thank you in advance!

Ivano C.

do not post duplicate messages

At least in the past, Mozilla has not built 64 bit XULRunner for Windows. However, at least some of the related Mozilla tickets have been closed, so perhaps one is already available. If not, you should be able to use the visual editor without any XULRunner installed, in which case the system browser (IE) will be used even though there will be a warning message about XULRunner.

If you have unregistered XULRunner but no editor is opened, check that the class you are trying to edit really is compatible with the visual editor (usually created with the correct wizard).

EDIT: These are the related Mozilla tickets:
. Note that there is no official version yet, but a lot of the sub-tickets have already been fixed.

This is a old version of the XULRunner, but I tested and works for me.

Windows 7 x64
Eclipse Indigo 3.7
Vaadin 6.4.7

I tried following the instructions at (ignoring the Aptna stuff), but still get the same popup. The editor still works, but was just trying to get rid of that annoying popup every time. No luck.

Win 7x64
Eclipse Indigo 3.7
Vaadin 6.4.7