Charts Widgetset missing?

I’ve included the new Charts package in my application, along with the commons-io-2.2 and gson jar files. I have recompiled the widgetset in Eclipse. When I run the program and try to create a chart, I get the message:

Widgetset does not contain implementation for com.vaadin.addon.charts.Chart.
Check its component connector's @Connect mapping, widgetsets GWT module
description file and re-compile your widgetset. In case you have downloaded a
vaadin add-on package, you might want to refer to add-on instructions

The widgetset did seem to compile - but I’m not sure what I should be looking for. My widgetset directory contains the file: JartWidgetset.gwt.xml and that looks like:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE module PUBLIC "-//Google Inc.//DTD Google Web Toolkit 1.7.0//EN" "">
        <inherits name="com.vaadin.DefaultWidgetSet" />

     Uncomment the following to compile the widgetset for one browser only.
     This can reduce the GWT compilation time significantly when debugging.
     The line should be commented out before deployment to production
     Multiple browsers can be specified for GWT 1.7 as a comma separated
     list. The supported user agents at the moment of writing were:
     The value gecko1_8 is used for Firefox 3 and later and safari is used for
     webkit based browsers including Google Chrome.
    <!-- <set-property name="user.agent" value="gecko1_8"/> -->
     To enable SuperDevMode, uncomment this line.
     SuperDevMode enables debugging of the client side of a Vaadin
     application using the JavaScript debugger of a browser. Java code is
     shown and debugging can take place on the Java level when using a browser
     that support source maps (currently Chrome, implementation under work
     for Firefox).
     After uncommenting this property, compile the widgetset once and then
     start the SuperDevMode server process in parallel with your normal
     server. Then add the command line parameter ?superdevmode to your
     application URL. Vaadin Eclipse plug-in can create a launch for the
     SuperDevMode server (Project Properties... -> Vaadin). 
     See for more
     information and instructions.
    <!-- <set-configuration-property name="devModeRedirectEnabled" value="true" /> -->

    <inherits name="com.vaadin.addon.charts.Widgetset" />

    <inherits name="com.vaadin.addon.timeline.gwt.TimelineWidgetSet" />

So can someone tell me what I missed? Or what I should be looking for? Thanks in advance,


Apologies for this one - a combination of rebooting the system, deleting the widgetset directory, restarting Eclipse… not sure what happened but now the chart is showing up…


I encountered the same issue. Could you please tell me how to fix it in detail. Does the system of “rebooting the system” mean your computer? Where is widgetset directory?

I was fumbling around a bit, so I’m not 100% sure exactly what fixed the problem. I did close and restart Eclipse, and then I closed Eclipse and completely rebooted the computer. I also rebuilt the widgetset at least twice. The widgetset directory is located in the src tree along side the rest of your code. It is just a directory named ‘widgetset’ and mine contains only one file - named JARTWidgetset.gwt.xml.

Eclipse has a a button along the top of the page that forces a widgetset rebuild - if you hover over it, I believe it says something like ‘rebuild widgetset’.

Hope that works for you,


I have the same problem with vaadin 7.1.6 using MyEclipse Pro 2013. It works fine with vaadin 6.8.12 before.

The gwt.xml file is deployed correctly, with associated compiled files.

  • src/main/java/my.package.ui.widgetset.ProjectWidgetset.gwt.xml
  • src/main/webapp/VAADIN/widgetsets/my.package.ui.widgetset/.

Using web.xml :

Vaadin application widgetset

The projet is build using maven.

Is there something missing in my project configuration?

I’m using the following settings in pom.xml

                    <extraJvmArgs>-Xmx512M -Xss1024k</extraJvmArgs>
                    <!-- We are doing "inplace" but into subdir VAADIN/widgetsets. This way compatible with Vaadin eclipse plugin. -->
                    <!-- Remove draftCompile when project is ready -->

The web.xml include following lines

    <servlet-name>Vaadin Application Servlet</servlet-name>
      <description>Vaadin application widgetset</description>
    <servlet-name>Vaadin Application Servlet</servlet-name>

Addons item are generated in VAADIN/widgetsets folder. Running the application still showing the error message. Is there something wrong in this configuration ?

Addons libraries are available in the WEB-INF/lib directory. And there is no error at compilation step.

I have the same problem with others addons used in the project. Is it a compilation or deployment problem?


I have cleaned widgetset directory but it still showing the same error.

Is it a problem with vaadin 7.1.6 ? should I downgrade to 7.1.5 or older ?


I had the same problem, the solution is that you need to define your Widgetset in your servlet. To do that follow these steps

1- Go to your UI class and before the servlet classs (public static class Servlet extends VaadinServlet) you will find a @VaadinServletConfiguration(productionMode = false, ui = Vaadin_testsUI.class)

2- add to this configuration your widgetset path so as to have for example :
@VaadinServletConfiguration(productionMode = false, ui = Vaadin_testsUI.class,

the name of the widgetset folder that you will find in your src file. In
is the name of the widgetset without the .gwt.xml extension. The last file is in the folder “com.example.vaadin_tests.widgetset”

3- Refresh your project (f5) and give it a try.

Hope this will work for you.

Sources :!/thread/4214612/9046291
Henri sara on vaadin wiki

I have the same problem but work with IntelliJ IDEA 14.0.1. Please, I would appreciate an answer to my question:

We are in 2015 and the IDE IntelliJ IDEA has version 1.0 of its plugin for Vaadin, however, I still have the same questions that Ricardo was four years ago, How to compile widgetsets in IntelliJ IDEA ?.

According to the documentation plugin 1.0, developed by the team of IntelliJ IDEA, The following features are available:

  1. Dedicated pages for creating a Vaadin project.
  2. Ability to create Vaadin components.
  3. Automatic setup of Google Web Toolkit (GWT) compiler for Vaadin custom widget sets.
  4. Support for debugging custom widget sets using GWT run configurations.

I ask them to concentrate on the number 3. Apparently this plugin can automatically compile the widget sets. Is it really true ?, not be compiled before the Add-ons, as is done in Elcipse?

I have been several days tried to execute an example of an Add-ons, the Graph-Explorer-demo-master, but I have no success. When buildingeverything goes well, but in the browser the following message appears:

"Widgetset ‘com.vaadin.DefaultWidgetSet’ does not Contain implementation for com.vaadin.graph.GraphExplorer. Check ITS component connector’sConnect mapping, widgetsets GWT module description file and re-compile your widgetset. In case You have downloaded to add vaadin -on package, you Might want to refer to add-on instructions. "

I guess the problem is that I have not compiled correctly the Add Ons. Any help?

Best regards.

Please, I need someone to tell me how to compile widgetsets in IntelliJ IDEA?

I have days trying this and no way to do this should be very basic steps in the IDE, but I can not find them. It is basic to start a development Vaadin.

I await a response.