Application hanging in bootstrap in IE10 - undefined.cache.js

happens to me since vaadin 7.1

In browser mode: ie10 / document mode: Standards, i cannot get past the bootstrap page. Vaadin tries to load a resource
, which is not available.

setting to browser mode: ie10 / document mode: ie9 makes everything run again, and the request for that undefined.cache.js never comes.

In addition, vaadin now seems to set

out of the box, which i can only override in quite a hacky way. But setting IE=9 is only a workaround anyway.

Did anyone else experience this problem? workaround-wise, what would be the best way to override that X-UA-Compatible setting? What’s up with that request fo undefined.cache.js?
Any information would be greatly appreciated.

using Vaadin 7.1.0 in an equinox osgi environment.

Change Header

Quite similar problem!/thread/290047 : the browser takes the first info it gets, so adding another header changes nothing. for the workaround i have to change the one vaadin adds before i get to the BootstrapListener.modifyBootstrapPage.!/thread/3618188 : the problem is that IE is already in “edge”, e.g. IE10 mode (as posted above). in IE9 mode everything works.

thanks for those links, but they had nothing to do with my problem - I did manage to find the problem. it seems you need to add ie10 to the user.agent property during widgetset build, or vaadin/gwt will search for an “undefined” permutation, even though there is no specific permutation for ie10. for anyone else having this issue, add the following to your widgetset.gwt.xml:

oh, and, btw. the application worked in IE10/Standards with vaadin < 7.1 without setting that property.

seems to be bug in vaadin… can you open a ticket for this?

As I investigate it is because of

When I compile widgetset with vaadin-maven-plugin I cannot see ie10 in the compilation-mapping.txt

Any comments?

As the result I cannot run my application in IE10-IE11:

Here is sequence

http://myhost:8280/myapp/				HTTP	GET	200	text/html	2,46 КБ	47 мс	обновление	0	0	47	0	0	102
/myapp/VAADIN/vaadinBootstrap.js			HTTP	GET	304	application/javascript	183 Б	< 1 мс	<script>	47	0	0	0	0	102
/myapp/VAADIN/themes/mytheme/styles.css			HTTP	GET	304	text/css	168 Б	< 1 мс	<link rel="stylesheet">	47	0	0	0	0	102
/myapp/VAADIN/widgetsets/mywidget/mywidget.nocache.js?1384505680220	HTTP	GET	200	application/javascript	15,47 КБ	15 мс	<script>	47	0	15	0	0	87
/myapp/?v-browserDetails=1&theme=mytheme&v-sh=1080&v-sw=1920&v-cw=1381&v-ch=466&v-curdate=1384505680221&v-tzo=-240&v-dstd=0&v-rtzo=-240&v-dston=false&v-vw=1381&v-vh=0&v-loc=http%3A%2F%2Fblackhost%3A8280%2Fmyapp%2F&v-wn=myapp-933929250-0.6479402878540375&v-1384505680221	HTTP	POST	200	application/json	5,22 КБ	46 мс	XMLHttpRequest	47	0	46	0	0	56
/myapp/VAADIN/themes/reindeer/legacy-styles.css		HTTP	GET	304	text/css	171 Б	< 1 мс	@import	47	0	0	0	0	102
/myapp/VAADIN/widgetsets/mywidget/undefined.cache.js	HTTP	GET	404		77 Б	31 мс	<script>	78	0	31	0	0	40
/myapp/VAADIN/themes/base/common/img/loading-indicator.gif	HTTP	GET	304	image/gif	152 Б	< 1 мс	background-image	93	0	0	0	0	56

Here is error in the server console:

INFO: Requested resource [/VAADIN/widgetsets/widgetse
t/undefined.cache.js] not found from filesystem or through class lo
ader. Add widgetset and/or theme JAR to your classpath or add files to <context>/VAADIN folder.

Adding into my widget gwt.xml solved my problem.

But I have a question related to this issue: is it necessary to explicit specify the user.agent property in my widget set? I thought before that is enough

I had a similar problem. I just created a undefined.nocache.js by hand and put one line in it:

xxxxxx.onScriptDownloaded(alert('This browser is not supported'));

where xxxxxx is the widgetset basename