Wigetset Compilation Fails and Vaadin Chart Key is not Recognised

Hello together i tried to add Vaadin Charts to my application however compiling the widgetset does not work for me from eclipse 4.4.0 Heres the sysout i get:

Updating GWT module description file...
Widgetsets found from classpath:
    com.vaadin.DefaultWidgetSet in jar:file:C:/Users/****/.ivy2/cache/com.vaadin/vaadin-client/jars/vaadin-client-7.6.2.jar!/
    ch.****.****.widgetset.****Widgetset in file://C/Users/****/AppData/Local/Eclipse/workspace_4.4.0/*****/src
    com.vaadin.addon.charts.Widgetset in jar:file:C:/Users/****/AppData/Local/Eclipse/workspace_4.4.0/*****/WebContent/WEB-INF/lib/vaadin-charts-2.0.0.jar!/
    com.vaadin.addon.timeline.gwt.TimelineWidgetSet in jar:file:C:/Users/****/AppData/Local/Eclipse/workspace_4.4.0/*****/WebContent/WEB-INF/lib/vaadin-charts-2.0.0.jar!/
Addon styles found from classpath:

Search took 13ms
Starting GWT compiler
08.02.2016 15:35:24 java.util.prefs.WindowsPreferences <init>
WARNUNG: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Compiling module ch.****.*****.widgetset.*****Widgetset
   Resolving com.google.gwt.validation.client.constraints.AbstractDecimalMaxValidator
      Found type 'com.google.gwt.validation.client.constraints.AbstractDecimalMaxValidator'
         Found type 'javax.validation.constraints.DecimalMax'
 Detected warnings related to 'javax.validation.Constraint'.   Is validation-<version>.jar on the classpath?
            Specify -logLevel DEBUG to see all errors.
 Ignoring unresolvable annotation type javax.validation.Constraint

License for Vaadin Charts 2 not found. Go to vaadin.com/pro for more details.

Widgetset compilation failed

It just wont recognise the key…

I have it in my homedirectory as file but it dod not work then i tried to pass it as JVM propperty
and finaly i even tried to pass it globaly trough the jvm like this

-Dvaadin.charts.developer.license=THEKEYHERE my least try was to pass it like this

System.setProperty("vaadin.charts.developer.license", "KEYHERE"); none of this workt with java 1.6 , 1.7 and 1.8 I have no idea what i am missing.

Thanks for your help.

(I had to censore some filepaths with ***** in the code but they are all correct)

Hello together, i finally found a solution which worked for me. I had my eclipse workspace locatet on a shared/network drive so i commited my project to SVN created a new workspace on my local “C:/” drive and pulled the project from the SVN in there. I tried again to compile the widgetset and it worked perfectly. I still dont know what exactly the problem was but i guess some issue with the workspace on the networkdrive.

Hi Jonas,

Thank you for sharing the solution with us :slight_smile: