WidgetSet Compilation with Vaadin 4.5.0.pre1

Hi folks,

I’ve tried to compile my project against Vaadin 4.5.0.pre1 and it seems that the newly gwt dependance gwt-user 2.1.0 relie on transitive dependence which have to be in the same version as gwt-user dependance.

One transitive dependance is gwt-soyc-vis and it seems it only exists in version 2.0.4 on maven central

I’ve also tried to force version of gwt-soyc-vis like this but it dosent work

org.codehaus.mojo gwt-maven-plugin 1.3-SNAPSHOT ${vaadin-widgets-dir} -Xmx512M -Xss1024k fds ${project.build.directory}/${project.build.finalName} true 8080 false compile resources compile com.google.gwt gwt-soyc-vis 2.0.4

and my error :

[gwt:compile {execution: default}]

using GWT jars from project dependencies : 2.1.0


artifact not found - Unable to download the artifact from any repository

Try downloading the file manually from the project website.

Then, install it using the command:
mvn install:install-file -DgroupId=com.google.gwt -DartifactId=gwt-soyc-vis -Dversion=2.1.0 -Dpackaging=jar -Dfile=/path/to/file

Alternatively, if you host your own repository you can deploy the file there:
mvn deploy:deploy-file -DgroupId=com.google.gwt -DartifactId=gwt-soyc-vis -Dversion=2.1.0 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url]


Has anyone experienced this issue with the newly vaadin release ?


it seems that formatting isnt working, I dont know why… Sorry for that

I am experiencing the same problem with the Vaadin 6.5.0 release.


Have you tried updating the gwt-maven-plugin dependency to 2.1.0-1? It seems there is no longer a gwt-soyc-vis for 2.1.0 and should be no dependencies to it either.

Indeed it was a gwt dependencie problem.

I sloved it by using 2.1.0-1 version.