Widgetset compilation problem


I’m having a problem with compiling the widgetset. Every time I put a new add-on or try to compile the widgetset, the following exception occurs:

java.lang.ClassNotFoundException: com.google.gwt.dev.GWTCompiler
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:315)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:330)
at java.lang.ClassLoader.loadClass(ClassLoader.java:250)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:398)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at com.vaadin.tools.WidgetsetCompiler$1.run(WidgetsetCompiler.java:61)
at java.lang.Thread.run(Thread.java:637)
Widgetset compilation finished
Widgetset compilation completed

And I cannot evade the problem by creating a new project, because this is a group project.
So does anyone knows a solution for this problem, because It seems I cannot get any vaadin add-on working without compiling the widgetset.

Thanks in Advance.

My guess is that you have used the Vaadin Plugin for Eclipse to create the project in one workstation and then shared the project with a developer group using a version control system. The problem with that is that the GWT Jars are not included in the project, but loaded by Eclipse to the Vaadin plugin configuration directory (under your Eclipse installation directory).

You can try to re-install the Vaadin Jar in the project preferences, under the Vaadin tab. In addition to downloading the Vaadin Jar, it should also download the GWT Jars to the plugin configuration directory. The update feature has occasionally had some problems with shared projects and may fail. I’m not sure if the problem has been fixed but if it fails, you may have to download the GWT Jars manually and put them in the the Eclipse plugin configuration directory manually. Another way to get the GWT Jars is to create a new dummy project that uses the same Vaadin version; creating the project will download the GWT Jars to the proper place in Eclipse and you can then remove the project.

An alternative is to download either Vaadin installation package or the proper GWT installation package from Google, copy the Jars (gwt-user.jar and gwt-dev.jar) to your project and add them to your classpath. You’ll have to upgrade them manually when you upgrade Vaadin. Well, the GWT version usually stays unchanged in maintenance releases of Vaadin.

Your guess is right. We are using version control system in our project.
I downloaded the 2 jar files (gwt-user.jar and gwt-dev.jar) and put them in the lib folder for the project (I don’t know if this is correct or not). I added them to the build path using Build-Path → Configure Build Path → Add Jars, then added them from the lib folder. But the problem still exists.

So did I do something wrong while importing them, or what should I do exactly ?

N.B: The problem only appeared when we tried to upgrade from version 6.2 to 6.3, as we needed the drag n drop in the newer version. So we removed the project and added it again and that’s when the recompilation problem appeared. Before we were able to recompile the widgetset without any problems.

Thanks for your help

I only want to recompile the widgetset on my PC, so is there any way that I can do this (either manually or automatically), is there any configuration need to be changed in order for me to be able to compile the widgetset again?

Note that I only need the add-ons to work locally

Thanks in Advance…

I don’t think it is a version control system related problem, I think there is a problem with the 6.3.1 release and the vaadin Eclipse plugin.

I have the same problem here.

If I create a new Vaadin project with 6.3.1 and add an vaadin add-on, e.g. sessionguard, I get the same error message. This is a clean, new vaadin project, not under any version control.

If I do the same again, but this time create a project with 6.2.6, the problem does not occur.

No I don’t think I have the same problem. This error only appears with me when I try to compile the widgetset of the version-controlled project. But if I make a project from scratch and choose the version to be vaadin 6.3.1 and add an add-on the widgetset compiles normally.
I’ll try to make a new project, and add all the add-ons that I need and then push it again, maybe this will work.

Alright I solved the problem.
I pushed another project on the Version-Control, and didn’t specify a run-time environment and everything went fine.

Same issue here. I dont understand what did you mean under the “I didnt specify the runtime enviroment”. What I am supposed to do?

you can try do this in eclipse
go to /eclipse/plugins/com.google.gwt.eclipse.sdkbundle_2.3.0.r36v201105191508/gwt-2.3.0
copy gwt-dev.jar and gwt-user.jar
paste gwt-dev.jar (replace) to /eclipse/configuration/com.vaadin.integration.eclipse/download/gwt-dev/2.3.0/
paste gwt-user.jar (replace) to /home/junkit/eclipse/configuration/com.vaadin.integration.eclipse/download/gwt-user/2.3.0