widgetset build with eclipse & NullPointerException


I faced problem when I tried to use Add-on in my project. I added Add-on to /web-inf/lib-folder.
After that eclipse informs that client code might have been changed and I should combile widgetset. When I answer yes to dialog build fails. Then I tried to remove add-on but my problem still exists.

Here is log from error:

!ENTRY org.eclipse.core.jobs 4 2 2010-05-16 10:06:15.337
!MESSAGE An internal error occurred during: “Compiling wigetset for project MyProject…”.
at com.vaadin.integration.eclipse.util.VaadinPluginUtil.findWidgetSets(VaadinPluginUtil.java:1816)
at com.vaadin.integration.eclipse.builder.WidgetsetBuildManager.compileWidgetsets(WidgetsetBuildManager.java:437)
at com.vaadin.integration.eclipse.builder.WidgetsetBuildManager.internalCompile(WidgetsetBuildManager.java:384)
at com.vaadin.integration.eclipse.builder.WidgetsetBuildManager.access$1(WidgetsetBuildManager.java:380)
at com.vaadin.integration.eclipse.builder.WidgetsetBuildManager$CompileWidgetsetJob.run(WidgetsetBuildManager.java:262)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Any ideas what might be the reason for error?

It looks like the Vaadin plugin for Eclipse tries to find widget sets from a folder, JAR, or zip path that is somehow invalid.

Not sure what the problem is, but the first you should always do is update your project in Eclipse (select the project and press F5). Perhaps something has been removed from the project outside of eclipse so it doesn’t find it.

Could be something else as well, such as a classpath problem.

In any case, the error is caused by an unchecked return value, so created a
ticket (#5032)
about it.


This might be also something related to Springsource Tool Suite. I’m using it for base installation of eclipse.

I need to check the functionality also with pure eclipse.

I also experienced the problem, in a project that does not use Springsource, but after the latest update in the experimental plugin its gone.

Use “[tt]
[/tt]” as the plugin path in the Install New Software dialog and install the latest integration plugin.

There still seems to be some problem that it detects the built-in DefaultWidgetSet in the Vaadin Jar as a widget set in the project and asks you to select the .gwt.xml that you want to compile. This might be the reason behind the original problem.