Valo Theme, Disable Panel


The function disable not apply as default. How I can do it?


what are you attempting to achieve? Do you have a picture, perhaps?

Best regards,


In my application I create a panel and add a status enable: panel.setEnabled(false), but the opacity doesn’t change. The panes is not enable but keep same opacity as enable panel.

I don’t think the panel opacity changes by default. Try something like the following in your theme:

.v-panel.v-disabled { opacity: 0.5; } -Olli

Thank you, this is work.
But I would like to know why the function disable works with other components y with panel don’t?

Hard to say; could be an ancient design decision that’s been kept around because nobody had a good reason to change it.



No problem, let me know if you have any further questions :slight_smile: