Vaadin Widgetset Version Problem

Hi All,
I am runing into a problem of my current version of Vaadin Widgetset Version is “out of sync” with my Vaadin Core. It was telling me that the version of the Vaadin Widgetset was build with an earlier version of Vaadin core. I have rebuilt the widgetset number of times. Nothing seemed working. The warning message persists. I had also “unwared” war file on my TomEE deployment to double check the widgetset build. The time stamp seemed are reflective of the new build. Not sure what I did wrong. Can someone offer me some suggestions? Many thanks in advance.

Here is the warning message I got when I ran my Vaadin application:

Sep 16, 2014 12:38:27 PM com.vaadin.server.communication.UidlRequestHandler checkWidgetsetVersion
WARNING:

The widgetset in use does not seem to be built for the Vaadin
version in use. This might cause strange problems - a
recompile/deploy is strongly recommended.
Vaadin version: 7.1.12
Widgetset version: 7.1.1

If you are sure that you 1) have recompiled the correct widgetset, 2) are using the newly compiled widgetset in your deployment, then the issue is most likely your browser caching the old one. A quick test: open your app in incognito mode in chrome and check the version numbers. Also, you can check if the browser takes the widgetset from cache or not under the network tab. Chrome is usually VERY insistent to use tha cache, even if you tell it to reload everything, multiple times. It is a bit annoying, really.

I am also facing the same problem. Its consistent with IE and Chrome, So I dont think its browser issue and warning message is seen when I run the vaadin application in any browser.

=================================================================
The widgetset in use does not seem to be built for the Vaadin
version in use. This might cause strange problems - a
recompile/deploy is strongly recommended.
Vaadin version: 7.4.1
Widgetset version: 7.2.6

We are using vaadin version 7.4.1 as mentioned in ivy.xml. I believe once version number changed in ivy.xml (earlier we were using 7.2.6), as the dependency has reference to vaadin version as: rev=“&vaadin.version;”, it should ideally compile widgetset with latest version of vaadin mentioned in ivy.xml i.e. 7.4.1 here. But seems it’s not hppening.
Appreciare any workaround to get rid of this error!

<!DOCTYPE ivy-module [

]>

    <dependency org="com.vaadin" name="vaadin-client" rev="&vaadin.version;"
         conf="widgetset-compile->default" />

Thanks,
Hari

Bonjour,
just for information, I face the same issue with vaadin version 6.8.17. And the widgetset version displayed on the ecplise console is 6.8.14.
It seems that the widgeset is succesfully compiled ussing the vaadin eclipse plugin. But the new widgetset is not deployed under the VAADIN theme, even if I try to compile the theme again.

Gilles

I’m facing this same issue too with the latest Vaadin spreadsheet 1.2.0.rc1 plugin. I’m using Ivy and I’ve tried to recompile the widgetset but without success. The following error occurs

=====================================================================================

The widgetset in use does not seem to be built for the Vaadin
version in use. This might cause strange problems - a
recompile/deploy is strongly recommended.
Vaadin version: 7.6.2
Widgetset version: 7.6.0

=====================================================================================

Could someone have any solution for this? I would really need that spreadsheet in my project. Thanks.

This is a long shot; sometimes hte Ivy plugin refuses to update the dependencies. Please double.-check that your classpath contains the correct version of the vaadin-client jar after you change the version number. If it doesn’t, try using the project Ivy menu to do a resolve and/or refresh.