Vaadin Spring Boot Starter throws MalformedParameterizedTypeException on ap

Hi, I’m a Spring Boot backend developer who is trying to ease his way in to Vaadin. I love the concept and as I understand it, Vaadin has a lot in commmon with GWT, which I used on several projects years ago.

I’m trying to get a Spring Boot app to use Vaadin, primarily because I loath front-end/JS/HTML coding and love the idea that Vaadin wil generate all the front-end “stuff” for me.

I created a simple [Spring Boot & Vaadin project]
( and uploaded it to GitHub. From what I can tell, I may have discovered a bug in the Vaadin Spring Boot Starter library. In that GitHub example, I’m pretty sure that I’ve pulled in the correct versions of the correct dependencies to get a simple starter app up and running, however on app startup I get this:

java.lang.reflect.MalformedParameterizedTypeException: null
	at sun.reflect.generics.reflectiveObjects.ParameterizedTypeImpl.validateConstructorArguments(
	at sun.reflect.generics.reflectiveObjects.ParameterizedTypeImpl.<init>(
	at sun.reflect.generics.reflectiveObjects.ParameterizedTypeImpl.make(
	at sun.reflect.generics.factory.CoreReflectionFactory.makeParameterizedType(
	at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(
	at sun.reflect.generics.tree.ClassTypeSignature.accept(
	at sun.reflect.generics.repository.MethodRepository.getReturnType(
	at java.lang.reflect.Method.getGenericReturnType(
	at org.springframework.core.MethodParameter.getGenericParameterType(
	at org.springframework.core.SerializableTypeWrapper$MethodParameterTypeProvider.getType(
	at org.springframework.core.SerializableTypeWrapper.forTypeProvider(
	at org.springframework.core.ResolvableType.forType(
	at org.springframework.core.ResolvableType.forMethodParameter(
	at org.springframework.core.ResolvableType.forMethodParameter(
	at org.springframework.core.ResolvableType.forMethodReturnType(

The full stack trace can be found by going to that GitHub project, cloning it and running the commands to package and run it.

It is important to note here that, although no Vaadin-specific classes seem to show up on the full stack trace, if you comment out the com.vaadin:vaadin-spring-boot-starter:13.0.8 dependency in the build file, and then comment out the Vaadin API code in the EmployeeEditor and MainView classes (so that it compiles again), the problem goes away and the app starts up just fine!

So there is clearly something in that Vaadin Spring Boot Starter that the core Spring Boot framework doesn’t like. Please advise!

And sorry if this isn’t the right place to report it, I’m happy to report it elsewhere if there’s a better way to go about it!

Have you tried using a newer version of the Spring Boot Gradle plugin, perhaps 2.0.0.RELEASE or newer?

Erik Lumme:
Have you tried using a newer version of the Spring Boot Gradle plugin, perhaps 2.0.0.RELEASE or newer?

I recomment that too. Out of curiosity I just copied the code from his repository to plain maven based spring boot starter project from and it worked ok. I saw also some dependencies in gradle file that are not needed.

Could you please create a ticket for this?
This is just a forum and not an issue tracker.
We will care about it if you create a ticket [here]
Otherwise it will be just forgotten.

Thank you.

The problem that you met is due to a missmatch in spring versions.
To get the project up and running just update the build.gradle dependencies I had the project running fine with the following configuration:

buildscript {
    repositories {
    dependencies {

plugins {
    id 'java-library'

apply plugin: 'org.springframework.boot'

repositories {

dependencies {


sourceCompatibility = 1.8
targetCompatibility = 1.8
String buildName = 'vaadin-spring-example'

jar {
    baseName = buildName

Thanks to everyone who pitched in with a quick response, especially you Mikael Grankvist, your solution worked immediately!

It is really refreshing to see a responsive support community, you all made me an instant fan of Vaadin!

Thank you again!