Vaadin Portlet v2.0 showing empty on Liferay pages


I created a vaadin project with Portlet v2.0 configuration in Eclipse, deployed the portlet to Liferay/Tomcat successfully, added the portlet to a page, but the portlet was displayed empty.
I tried with the code generated by the tool: the main window containing a label with the text “Hello vaadin user” on it, and also tried code example and None of them worked.
I haven’t got any exceptions neither on deployment nor on adding the portlet to a page.

If I choose Portlet v1.0 configuration, it works fine, the portlet content is displayed properly on the Liferay page.

One of my colleagues also created the portlet application with “New Vaadin Project” -Wizard and used portlet version 2.0 and the portlet displayed nothing. When he instead created the portlet for version 1.0 it displayed the created portlet as it should.

Some version information:

  • Version: 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7
  • Build id: M20090917-0800

Vaadin: 6.2.1
Liferay: 5.2.3
Tomcat: 6.0.18

Do you have any suggestion how to get the portlet v2.0 display properly?

Just a guess, but have you installed the theme and the widgetset on the Liferay portal?

A JSR-168 (Portlet 1.0) portlet can serve them directly through the servlet that is behind the portlet, but a JSR-286 portlet does not have a servlet and cannot serve static resources with fixed URLs.

Liferay 5.3 will have these installed out-of-the-box but until then, take a look at
this article

Note that if this is the case, you should eventually get an error message from the browser about not being able to load the widgetset if you wait long enough.

Thank you very much, Henri!

I followed through the steps at and now the Portlet 2.0 show properly!

Additional note: the themes and widgetsets were not installed on the Liferay portal, indeed as you guessed, but the browsers (neither IE8, nor Firefox) did not show any error message - at least not what I could notice.

Thanks for the help!