Vaadin portlet in eXo portal


Just wondering if anyone has managed to get a Vaadin portlet to work in the eXo portal platform? I’ve tried it but when I called getContext(), it doesn’t return me the expected PortletApplicationContext, instead it returns me the WebApplicationContext.

I’ve tried this on eXo portal 2.6 and the portal integration is based on the PortletDemo in the demo.

I’m not sure if it’s because I’m missing some eXo configuration or not, but it does seemed straightforward to deploy a portlet to eXo. If anyone’s managed to deploy this successfully, would be grateful if you can let me know. Thanks.

I’m having this problem (WebApplicationContext instead of PortletApplicationContext) also on liferay… It would be fine to know what causes it!

I would recommend you try using the new portlet 2.0 features. The portlet 1.0 uses both a servlet and a portlet and if the sessions are not shared between the two you will never get it to work. There might also be other issues which are not present in the portlet 2.0 support.