Vaadin plugin for Eclipse does not offer to recompile my widgetset.

Why would the Vaadin plugin for Eclipse fail to offer to recompile my WidgetSet when installing an Add-On?

I am adding the
Switch add-on
to my project. I am following the instructions at the middle (around 2 minutes) of
this video

I drag the “switch-0.94.jar” file I downloaded into the Eclipse > Project Explorer (tab) > myProject (tree item) > WebContent > WEB-INF > lib. The jar file does appear there. But Eclipse does not offer to recompile my widgetset for me.

I try doing a “clean” build of my project, and restarting Eclipse. But no go. When I run the app, the following error message appears in the browser window, located where the Switch widget should appear:

I’m having no other problems in Eclipse, and have successfully built the app from the long Tutorial.

I am using…
Eclipse Version: Indigo Release Build id: 20110615-0604
Vaadin Plug-in for Eclipse
Vaadin: vaadin-6.7.0.beta1.jar
Mac OS X 10.6.7 on Intel Mac, 6 gigs memory
Java version “1.6.0_26”

You can manually trigger the recompilation by pressing the “compile widgetset” in the top bar - a cogwheel with a Vaadin logo. Why it doesn’t suggest it directly - no sure. Maybe it doesn’t recognize the project correctly. Try updating the Vaadin plugin, and check that “project → properties → project facets” has the “Vaadin Plug-in for Eclipse” checked.

Solved. :slight_smile:

(a) Yes, “project → properties → project facets” for “Vaadin Plug-in for Eclipse” was already checked on my project. So I still have no idea why the plugin fails to offer to re-compile widget set.

(b) Thanks for pointing out the “Compile Vaadin widgets” button in the main toolbar of Eclipse. That worked. Took about 4 minutes on my MacBook, so be patient. After a “clean” rebuild, I ran my app, and the Switch widget appeared properly. I did not even need to restart Eclipse.

Also make sure “Project properties → Vaadin” does not have the “suspend” option selected for widgetset compilation. You might have accidentally disabled widgetset compilation in the dialog that pops up when Eclipse thinks you need to recompile the widgetset.

Thank you all. It solved my problem.

thanks guys i had a similar problem but now it’s all good. cheers

Thanks for the solution… helped me

I can’t find this toolbar :frowning:

Ok, here we go … My Eclipse has the build button enabled, but when clicked, no information is displayed on the console, and no file is generated in WebContent/Vaadin/widgetsets/. It is a simple project created with Eclipse Plugin, and then added Widget (New->Vaadin->Vaadin Widget);

What can be happening? Where can I debug, investigating?

compilation Verbose output

Window → Show View → Other… → Error Log

Thank you very much. It was the wrong JAVA JRE (Windows) path.

Wrong: “C:\Program Files\Java\bin\java.exe”
Correct: “C:\Program Files\Java[b]

Hi ,
i have also same problem, where can i find the

Compile Vaadin widgets

" button in the main toolbar of Eclipse ? i did not find.

Sorry i found it.