Vaadin + JBoss

I am unable to deploy vaadin application on JBoss 5.1 AS server.
Can somenone list steps for the same.

P.S. I even tried deploying vaadin default project using making a .war file by Export option.

It shows Http error 404 - requested resource not found.
But when I keep .html file in contextPath (in war file directly), I am able to access that html file).

Kindly respond, Thanks in advance :slight_smile:


first thing to check is that your project has a web.xml file in WebContent/WEB-INF folder. I think the vaadin plugin creates servlet api 3.0 compatible projects by default and those have no web.xml, but JBoss 5.1 only supports servlet 2.5.


Thanks for responding Teppo Kurki.

I have created basic vaadin 6 project which support servlet 2.5 and has web.xml file by default.
No sigle edits done on project, tried deployin it as it is to show Hello message atleast. but no success.
JVM used - 1.7
I am able to deploy on Apache Tomcat without issue.

I am impressed with UI controls Vaadin provides, and have created a Demo app, if its able to run on JBoss 5.1 AS server I can think of going with Vaadin Framework.
P.S. but can’t compomised on JBoss server used. As it host other apps too.


ok then the setup should work in general so obviously something is going wrong. Would you be able to post your demo app somewhere so it would be possible to take a look at it? Also any log output from your JBoss instance while it’s trying to deploy the war file could be useful.


Log stmts -
01:22:03,574 INFO [TomcatDeployment]
deploy, ctxPath=/admin-console
01:22:04,518 INFO [config]
Initializing Mojarra (1.2_12-b01-FCS) for context ‘/admin-console’
01:22:08,676 INFO [TomcatDeployment]
deploy, ctxPath=/
01:22:08,827 INFO [TomcatDeployment]
deploy, ctxPath=/jmx-console
01:22:08,919 INFO [Http11Protocol]
Starting Coyote HTTP/1.1 on http-localhost%2F127.0.0.1-8060
01:22:08,944 INFO [AjpProtocol]
Starting Coyote AJP/1.3 on ajp-localhost%2F127.0.0.1-8009
01:22:08,950 INFO [ServerImpl]
JBoss (Microcontainer) [5.1.0.GA (build: SVNTag=JBoss_5_1_0_GA date=200905221053)]
Started in 57s:889ms

From statments, surely its not deploying may project.
Have a look at attached screen shot.

or how can I go about posting my demo app, pls. suggest. [ This is default Vaadin 6 project, once it gets deployed proprly then I will try deploying my app. As before i didnt get success with Demo app so tried creating default vaadin app for testing]

24211.txt (16 KB)


seems to me it’s not even trying a deploy; I can’t see anything related to your vaadin project in the log.

Maybe zip up the test project folder and attach it here or put to dropbox or some other service and provide a link?


Here it is -

Hi again,

I tried it and could not get it to deploy. Exactly nothing happens when I drop the war file into jboss deploy folder. Unfortunately I see nothing wrong with the project so I don’t know what’s going on. Jboss does not give any kind of output to me.

Maybe someone else can help.


:frowning: ok
btw thanks for trying this out.
I hope someone comes up with success.

Is this a bug with Vaadin app not getting deploy on JBoss server ?
Can you give me clue on how to put this truoble to vaadin’s team ear.

I am kinda desperate in solving this. :slight_smile:

I’m not sure where the issue is since JBoss is not outputting anything. I’d probably do the following if I had the time:

  1. Find out if there’s a way to enable debug or verbose output for jboss/deployer so there would be something to look at in the log.
  2. Double-check that a non-vaadin web app deploys correctly when done the exact same way as the vaadin app.
  3. If not solved at this point, create a ticket at and hope someone picks it up.


Thanks A Ton macha.

I resolved it. Just reinstalled JBoss server.