Vaadin IPC and Liferay 5.2.3

Hi All,

First of all, we appreciate the great work done by the Vaadin team. Love the beautiful UI with just plain JAVA.
We are trying to use Vaadin as portlets in Liferay version 5.2.3(using tomcat 6.0.20). The main Vaadin components do work in Liferay 5.2.3.
We encountered several issues in trying to use Liferay IPC which is very critical for our app.

We are trying to use the Liferay IPC 1.0.0 with Vaadin 6.7.9.

To compile the liferay ipc widgets we tried the latest liferay control panel addon (1.0.1), which doesn’t work in 5.2.3(java.lang.ClassNotFoundException: com.liferay.portal.kernel.exception.SystemException). Hence we tried to use an earlier versions and the latest one which installed with 5.2.3 liferay was
liferay ipc 0.9.0. We tried to compile Liferay IPC 1.0.0 with this addon. The frontend does show that the compilation is successful but on the server we get an error

java.lang.NoSuchMethodError: with
Exception in thread “pool-3-thread-1” java.lang.NoSuchMethodError:;Ljava/io/File;)V
at com.vaadin.integration.liferay.controlpanel.util.WidgetsetUtil.backupOldWidgetset(Unknown Source)
at Source)

We did update the latest commons-io jar too.

We are not sure if the IPC widget is really compiled successfully. When we add the liferay IPC component to a layout we get an error like below:

com.vaadin.addon.ipcforliferay.LiferayIPC(NO CLIENT IMPLEMENTATION FOUND) id=PID2 A_EV_IDS=

Even if we successfully solve these issues, Liferay 5.2.3 uses" trigger" and “bind” methods, will the liferay IPC(document talks about "fire’ and “on” methods) work for these methods?

If any one has successfully used Vaadin IPC in Liferay 5.2.3 please let us know the steps you have taken.
A move to liferay 6 is not possible at this moment for various reasons.

Any help is really appreciated.


Just to update, I was able to compile widgetset using 0.9.0 addon (replacing commons-io jar). There are no client side errors but like I have expressed in my previous post
the liferay IPC is looking for “fire” and “on” methods(which are liferay 6.0 specific). The error I get when I use eventListener and sendEvent are :
JavaScriptException: (TypeError): Object [object Object]
has no method ‘on’ and
JavaScriptException: (TypeError): Object [object Object]
has no method ‘fire’
methods respectively on the vaadin debug window.

A work around would be good to know, otherwise a migration to liferay 6.0 is inevitable in our environment.

Thanks for any help.

Downloaded the source and modified the liferay IPC events to '“fire” and "bind " and IPC works in liferay 5.2.3 too.

Hi which commons-io.jar did you use…I am getting the same exception while compiling the wedtset…can you please reply as soon as possible.

You can use the latest commons-io.jar. I don’t remember the version but it’s of size 184,320. You need to extract the control panel war file and then replace the commons-io.jar in it.