Vaadin Directory fails to load

Right now (20:37 MSK) the Directory seems to be down. Hope Vaadin guys already know about it.

Loads for me. Do you get some sort of an error message or…?

What seems to be the problem? It loads fine for me.

Thanks for fast reply!
Firebug says:

missing ; before statement
 ),a).ctrlKey&&!a.altKey&&!a.shiftKey&&...$new Object( );a.preventDefault()}}}}\n (line 1305)


SyntaxError: Unexpected identifier

Tried clearing the cache, didn’t help.
Yesterday everything worked as it should.

Which browser are you using? Or did you try with multiple browsers and get the same error?

I tried Firefox 3.6.3, Chrome (latest stable) and Opera 10.0. You can see error messages in my previous post.
Not sure where the problem was but now it works fine. May be some GWT surprise? Hope not.
BTW, what should we do if such error appears in Vaadin/GWT application? Recompile/redeploy or wait and pray?

Excuse me for disturbing you. The problem is somewhere in my environment and the Directory is not the only app affected.

update: problem solved, uninstalled AVG.

See also
Other problems with AVG
Maybe we need a FAQ / Gotcha page.

Such behavior was brought to us with the latest AVG updates. Sure, they will fix it some day but just imagine how many users were affected. It took me 4-5 hours to determine who is to blame bacause the first thing I tried was disabling AVG components and it didn’t help. When I saw the difference between broken and original (retrieved via https) pages, the solution was obvious.

Original: $,this.l,c);
Broken:   $new Object( );