Vaadin Charts

After installing Vaadin Charts, my email function in my application doesn’t work anymore. I am getting the following error:

Caused by:$CallNotFoundException: The API package ‘mail’ or call ‘Send()’ was not found.

at at at at at javax.mail.Transport.send( at javax.mail.Transport.send( at com.vdc.components.Email.send( at DefaultReminderProcess.SendEmail.sendEmail(

When I remove the dependency for Vaadin Charts from Ivy, then I don’t have the problem anymore and my email function works again. Switching the dependency back on, and I will have the problem again.

	<!-- <dependency org="com.vaadin.addon" name="vaadin-charts" rev="1.0.1" /> -->

I am deploying my application on Tomcat and I have a clean Eclipse IDE (no Google App Engine SDK installed).

It looks like as if with the Vaadin Chart dependency Google AppEngine jars are linked to my application.

Anybody who has a suggestion?


I suppose you are using Vaadin Eclipse plugin and its IVY stuff to build your war file? I tested with an empty project and checked the war file: no app engine dependencies for me. I really haven’t used IVY that much, but I know enough from it (and Vaadin Eclipse plugin) to suggest using a proper maven project instead :slight_smile:

So far adding conf=“default->default” to dependency declaration has solved all issues. Like this:

I think with with latest versions of our eclipse plugin that “default->default” is now default and no more needed.

If this don’t help I guess I can’t help without more info about your project.


Hi Matti,

First of all: Sorry for my late response. I left the issue and worked on an other part of my application. Frustrated I was.

But your assumption is right: I use the Vaadin Eclipse plugin and its IVY stuff to build my war file. The issue is indeed solved by adding conf=“default->default” to the dependency declaration.


I will consider your suggestion to make it a proper Maven project.