Vaadin app suddenly will not load

I started testing and developing based on the Spring Security sample and everything was good.
After a while of some live reloads, it started complaining about some NodeJS dependencies.

I stopped the app, ran npm prune and npm install.
After that I ran mvn clean and mvn install.

Now the server boots up but I can no longer load any page.
Javascript console reveals this:
Path '/login' is not properly resolved due to an error. Resolution had failed on route: '(.*)'

As well as this:

Uncaught (in promise) DOMException: CustomElementRegistry.define: 'dom-module' has already been defined as a custom element dom-module.js:163
    ready vaadin-router.js:1820
    (Async: promise callback)
    render vaadin-router.js:1812
    __onNavigationEvent vaadin-router.js:2227
    setRoutes vaadin-router.js:1714
    <anonymous> index.ts:14
    ts vaadin-bundle-b7a90f090f738c0db4ff.cache.js:236
    __webpack_require__ vaadin-bundle-b7a90f090f738c0db4ff.cache.js:64
    <anonymous> vaadin-bundle-b7a90f090f738c0db4ff.cache.js:199
    <anonymous> vaadin-bundle-b7a90f090f738c0db4ff.cache.js:202

When building the app I get additionally this in the output, but perhaps it was there before:

 424 bytes {bundle} [built]

    + 605 hidden modules
Child html-webpack-plugin for "index.html":
     1 asset
    Entrypoint undefined = index.html
 659 bytes {0} [built]

 528 KiB {0} [built]

 472 bytes {0} [built]

 497 bytes {0} [built]

What is wrong? Is it something I changed? Is it not allowed to invoke npm?
How can a build that just worked a second ago suddenly stop working without a single error message?
I was only making changes inside a single component.

Still do not understand why this happened or why what I did solved it, but I was able to start it again by manually deleting the following files:


Then running mvn clean, mvn install and starting the app via Spring Boot…