vaadin 7 plugin for eclipse

I want to use vaadin 7. While downloading latest vaadin plugin for eclipse, I am getting following error:

An error occurred while collecting items to be installed
session context was: (profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.apache.ivy,2.3.0.cr2_20121105223351
No repository found containing: osgi.bundle,org.apache.ivyde.eclipse,2.2.0.beta1-201203282058-RELEASE

Please help me in resolving this issue.

This works for me:

I hope you installed IvyIDE before the Vaadin plugin, as
described here

Thank you very much. Links given by both of you helped me in resolving the issue. Now I have successfully installed the plugin for vaadin 7.

I am installing vaadin 7 plugin in eclipse and getting the below error:

An error occurred while collecting items to be installed session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at

By the way, I have installed Apache Ivy.

Your error sounds a bit like a (temporary) connection problem. Please try again, possibly restart Eclipse. If it doesn’t go away, it could be something else.

For some reason, it worked when I disable my anti virus program temporarily.

+1 Thanks Jennifer that worked for me too.

I resolved this issue by manually downloaded the .jar file from the error result url “” . Just copy the url and paste into the browser, save the .jar file into Eclipse/plugins directory . Then try to install vaadin 7 plugin again and hope this time it will be resolved, It worked for me.

Hi Guys,

I got the same problem which is expecting one of the dependecy missing from IvyDE Plugin,

The I went ahead and updated the IvyDE update by using this url :

Then went ahead to market place and added the Vaadin plug in