Vaadin 7, Maven, Eclipse, Tomcat


I have been struggling quite a lot to get Vaadin 7 to play with Maven and Eclipse using Tomcat. As I assume that this combination is quite mainstream, it’s really surprising that it’s so difficult to get this up and running.

Maven seems to be the problem as I can easy create a working project using the Vaadin Eclipse plugin.

More specifically:
Using the vaadin-archetype-application 7.0.0 creates a widgetset and a rererences to it in web.xml that’s causing problems. “Failed to load the widgetset: ./VAADIN/widgetsets/”

I tried many things to compile the widgetset but it fails with the same error.

What would be really nice is to have a comprehensive guide that works.



Ok I figured out that it’s not that complicated once you know how to do it.

  1. Create a Maven project using the Artifact-Id “vaadin-archetype-application” ver 7.0.0
  2. Run the Maven goal vaadin:compile
  3. Do a full refresh on the project (very important)

I think my problem was that on one of my computers I had a faulty Eclipse install. Once I fix this all is working fine.


I think that Eclipse doesn’t automatically notice changes to the project done outside of eclipse, so if you do something on the console, you have to always refresh it after that.

Yes, definitely, but it’s even the case using the Eclipse .m2 plugin; doing a full refresh is necessary.



I also try to create a maven project in m2e, but the project has a cross just after I have installed it.The Pom file appears to have problem as an error appears in the “packaging” line says " Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-resources-plugin:2.4.3:resources (execution: default-resources, phase: process-resources)
Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-resources-plugin:2.4.3:testResources (execution: default-testResources, phase: process-test-resources)"

And by the way how did u run the maven project, using command line or the Tomcat server in Eclipse?

i had tried this in eclipse luna as Jan did;

  1. Create a Maven project using the Artifact-Id “vaadin-archetype-application” ver 7.0.0
  2. Run the Maven goal vaadin:compile

and successfuly compiled but when I run it in Tomcat7 I got this error, any advice? where I am missing?

First of all, please use the latest version of Vaadin, 7.4.3 if you are starting a new project now.

Once you have created it with maven, run mvn package mvn jetty:run
After that, your app will be up on http://localhost:8080. If you prefer using tomcat, deploy the artifact from step 1 in Tomcat (preferably trhough your IDE for development ease)