Vaadin 7 default project, Newbie Question


Newbie Question

I just downloaded Eclipse Juno, 4.2. If I create a Vaadin 6 project and run using the Jetty J2EE preview everything looks fine. I see the “Hello Vaadin user.” If I create a Vaadin 7 defalt project, instead of seeing a button that says “click Me” I see “Directory” and my class name, “META-INF 0 bytes…” It looks like it is not running the code. It looks like an error. Is this the problem described in ticket 10962?

Is there a way around this ?


I ran across this same problem and I finally found a workable solution. Note I’m using the latest install of Eclipse Kepler (SR1) and the Vaadin plugin (7.1.10) at the time of this post. Also, I run Eclipse on an Apple iMac but the instructions for Jetty should work for Windows.

  • First go to the Eclipse Marketplace (Eclipse menu Help->Eclipse Marketplace)
  • Enter runjettyrun and when it’s displayed go ahead and install it and re-start Eclipse.

The next part is not very elegent becasue you have to start and stop the server to get a working Run Configuration but it’s quick and it works.

  • Right click on the Vaadin project and select the menu item “Run Jetty” Note that this will bring up Jetty 6 which will give you the same issue.
  • Stop the server you just started buy selecting the stop icon (the red square icon) in the console tab.
  • Select the Eclipse menu item Run->Run Configurations and select your project unter the Jetty Webapp that matches your project.
  • You will see a Jetty Version dropdown that probably showing Jetty 6. Use the dropdown to change that to Jetty 8.
  • Select the “Apply” button" and select the “Run” and it should work

Now all you have to do to run this again is right click the Project and select Run As (Or Debug As) and select “Run Jetty” and it will run Jetty 8 from now on.

Some notes:

  1. You can also run the project by selecting the down arrow next to the Run icon (the green circle with the white triangle) or Debug icon (the bug) and selecting the project from the list. Be careful though as these icons are rather small and if you click on the icon itself (and not the arrow) you will immediately launch a run confuration (not a bad thing just be aware).

  2. If you try running the project and it is already running it will attempt to run it anyway. When that happens to me I go to the console tab and close the running server then select the arrow next to the icon in the console pane that looks like a monitor (and has the tooltip that says “Display Selected Console”), switch to the other running session and close it too.

  3. I also got this to work by installing the BitNami version of Tomcat and setting that up as an Eclipse Server. I chose BitNami because they were in the Mac App Store so installing it was Apple Simple. Note that this is different and separate from runjettyrun so it’s not really related to getting Jetty running but I thought I’d mention it in case you’re interested in using Tomcat.

Hope this helps.



Thank You, works great.

To see the web page I run Chrome and paste in the URL

Is there a way to see the page within the Eclipse IDE, without running Chrome (or whatever)?

Thanks Bill

Glad it worked. As far as running everything in Eclipse you can click on the Web Browser Icon (looks like a globe on the toolbar at the top of the Eclipse window with the tool tip “Open Web Browser”) and paste the URL into it’s address field. This is the best I can come up with as I don’t usually run it that way (I use Firefox or Safari for my testing) so I don’t know of a way to get Eclipse to launch it’s browser automatically using RunJettyRun.