Vaadin 7 and embedded Jetty ... again

With vaadin 6 it was easy to start vaadin with embedded jetty.

When trying the same in Vaadin 7, i just get the Directory structure when starting the Server.
Shown in the browser:

Directory: /
META-INF/ 102 bytes Dec 19, 2014 11:57:59 AM
VAADIN/ 102 bytes Dec 19, 2014 11:58:00 AM
WEB-INF/ 102 bytes Dec 19, 2014 11:57:59 AM

The server starts, but how can I point to the right Servlet (main UI Class) ?

I have looked at many of threads in this forum.
I have tried vaadins
embedded Jetty launcher
combined with the default project created by eclipse plugin, with the same result as above, using: http://localhost:8888

trying: http://localhost:8888/MyApp (main UI class) gives 404

Any suggestions / examples of how to set up embedded jetty with vaadin 7.

It worked when I specified the servlet in the web.xml
the web.xml was not needed when running in TomCat

I’m trying vaadin 7.5.10 and having mixed results.

I’ve created the project from the mavan archtype, then imported the maven project into exclipse.

I’ve also tried to create the project from eclise using the vaading plugin - but same mess in the end.

When I build the project in eclise I get a directory structure that makes zero sense (to me) in the target war.

META-INF (ok that looks good)
VAADIN (ok for static resources )
WEB-INF (what I would expect in a war)
what is this?
------WEB-INF (
what is this doing here?

when i try and run the application i get the following error

Requested resource
[/VAADIN/widgetsets/com.vaadin.DefaultWidgetSet/com.vaadin.DefaultWidgetSet.nocache.js] not found from filesystem or through class loader. Add widgetset and/or theme JAR to your classpath or add files to WebContent/VAADIN folder.

could anyone tell me what is all of this stuff and where does it belong in the war

thanks for your help