Vaadin 7.7.0 widgetset problem

Hello there,

I had a working appilcation based on Vaadin 7.6.4 and Spring Boot.
I wanted to add an add-in and because of the hustle with compilation I decided to go for Vaadin 7.7.0 (it was a nice coincidence that it was just released).

However when I changed my Vaadin version and added these lines to vaadin plugin in pom.xml

my application stoped working. More precisely vaadin:compile is successful. But when I run it as a Srping Boot appilcation (from InteliJ, this is what I was using before) I don’t have any exceptions but the page looks totally plane without any Vaadin gui (something like plain html) and of course it doesn’t react to any events and so on.

When I remove cdn then I have a lot of Broken pipe exceptions and the same result in the browser.

I have Spring security configured as well, if that changes anything.

I also tried with @ServletComponentScan(“org.peimari.dawn”) which I saw from the example online. This results in exceptions

Since I am not the maven expert it can be that I am doing something stupid, but so far nothing seems to work.

I use InteliJ Run Spring Boot application which was working fine till now.
Is it neecessary maybe to execute some other maven goals to run application…?

Please help!
Thanks in advance…

27602.xml (7.11 KB)

Do you get any errors on the client side? You can check that with
Chrome DevTools
for example (check the console tab). Maybe CSS files are being blocked by Spring Security for some reason.

Hello everyone,

My Vaadin version is correct 7.7.0 in local and in production mode.

Still, I’m having difficulties to update my widgetset version from 7.6.7 to 7.7.0 in production mode…

-I’ve added into the maven goals : vaadin:update-widgetset = no effect…
-I’ve restarted the server, my widgetset version is still 7.6.7

Any idea anyone ?
Thanks for helping,


Did you execute
mvn vaadin:compile

Hi Alejandro,

In my build maven goals you mean ?

thanks for your reply

I mean, you have to run that goal to compile the widgetset.

Here is my pom plugin :

                <extraJvmArgs>-Xmx512M -Xss1024k</extraJvmArgs>

The goal compile + update widgetset should do the job don’t you think ?
Doesn’t seems to work :confused:

What do you get with mvn vaadin:compile? Any errors?

No errors on production mode but still having the same issue :confused:

The widgetset in use does not seem to be built for the Vaadin
version in use. This might cause strange problems - a
recompile/deploy is strongly recommended.
Vaadin version: 7.7.0
Widgetset version: 7.6.7

Still my bet is that the widgetset is not being compiled. Please try executing the follow command in a terminal and paste the result here if it doesn’t solve the problem :slight_smile:

mvn vaadin:compile

Sorry was in a meeting, I will test it thanks

Hi all,
I still have difficulties to update the widgetset version on production mode.
I’ve deleted the target - add the correct compile and update widgetset on maven goal build… (on teamcity)
mvn vaadin:compile is done but version is still the same…


In Dev mode I get no problems…
Could you give me a hint please,

Thanks again,

Hi everyone,

Alleluia !! Widgetset version is now 7.7.0 :slight_smile:

The solution was to delete the target of course AND to delete the widgetset folder in : webapp/VAADIN/widgetsets

The mvn clean doesn’t delete it…
So problem solved for me…
Thanks for helping !