Vaadin 7.6.x application won't load on Android Chrome 48

We have several applications that we recently upgraded to Vaadin 7.6.1. Just noticed that they won’t load on the latest Android Chrome, version 48 (specifically v48.0.256.95, see screenshot). We tried this on several Android devices (ranging from smartphones from different manufacturers, to tablets) running Chrome 48, and still got the same issue, so it’s not isolated to one smartphone. Note: everything works fine on iOS devices though.

Important to note that when we downgrade Vaadin back to 7.4.5 the applications load fine on Chrome 48. OR, if we downgrade to Chrome 40, then Vaadin 7.6.1 applications load fine. So there seems to be some incompatibility with Vaadin 7.6.x and Chrome 48. Furthermore, it’s not just our applications. I tried loading the Vaadin QuickTickets demo ( on Android Chrome, and get the same issue.

Chrome gives a very vague message: “Aw, Snap! Something went wrong while displaying this webpage”. See screenshot. Can’t find out any more details on the specifics of the error using debugging.

Anyone know what’s going on?

It looks like network problems. Your browser can’t reach the server at all.
Check network connectivity, proxy settings, data saver settings etc.

Definitely not a network issue. Browser can reach the server just fine. When we downgrade the same server to an older Vaadin Version, it starts working on Android Chrome 48. Just not when the server is running Vaadin 7.6.x.

Update: Looks like the issue is no more in Android Chrome 49.