Vaadin 24 - modifying pom.xml the version from 24.0.0 to 24.0.2 - APPLICATION FAILED TO START

When I updated pom.xml for chaning the version number vreom 24.0.0 to 24.0.2, I get error


APPLICATION FAILED TO START


Description:

Failed to configure a DataSource: ‘url’ attribute is not specified and no embedded datasource could be configured.

Reason: Failed to determine a suitable driver class

Action:

Consider the following:
If you want an embedded database (H2, HSQL or Derby), please put it on the classpath.
If you have database settings to be loaded from a particular profile you may need to activate it (no profiles are currently active).

Before the change, everything was working fine. Database accewss was working before the change.

I wonder what else do I need to modify?

Thanks

The database driver has nothing to do with the Vaadin version. Did you happen to change something else and maybe did not run mvn clean until now?

I cleanded the project and updated Maven. but did not help

nothing else has changed.

even if I revert back to the original 24.0.0 version, the problem remains.

I use eclipse

The problem was fixed by modifying the properties file by just adding an empty line and saving it.