(Urgent)Issue with Vaadin Integration in the present SpringBoot project

Hello everybody,I am new to Vaadin and facing issue when in an ongoing backend SpringBoot project I want to add Vaadin.
I added all required Vaadin dependencies in build.gradle But when I am running the project. It gives
**Vaadin build in production mode **
and when i go to the localhost url there I am getting
Project Base for Vaadin requires an internet connection to work. You do not seem to have access to the server right now. Check your internet connection and try reloading the page to use the application.
I am attaching the images.
Could someone please help me in this.
Its urgent.

So many possible problems; check your setup against an example downloaded from start.vaadin.com

I did that but still giving issue

If you don’t have network available, this can also happen - just enable wlan

I have an internet connection and I am also able to run any other Vaadin project from start.vaadin.com

Sounds like your project setup is not right :grimacing:

might be ,but i am not getting the point of error.I added all required vaadin dependencies from a starter vaadin project into my springboot project and its building all the required stuff like preparing vaadin frontend and all but showing error at localhost url.

can u provide me any project zip in which u have added the vaadin afterwards in the springboot project.

Just get a project from start.vaadin.com - it contains spring boot; just add the Vaadin dependency AND maven profiles and done

yes i have followed the same but still getting this issue

Based on the log your tomcat port is somehow non-standard (usually 8080). It should not be a problem, but you could maybe try with the default.

It’s also build with production mode with dev mode enabled, totally unorthodox setup

@quirky-zebra what do you mean by dev server mode enabled could you please elaborate how to fix this

I don’t know how to fix it cause I don’t know what you have done wrong without seeing your pom

its a gradle project and i have not set any dev mode in build.gradle

Urgh Gradle… easy to fuck up :grimacing:

https://github.com/vaadin/base-starter-spring-gradle here is a example