Uploading a new addon: ListenerMethod$MethodException: Invocation of method

I’m trying to upload a new addon I’ve developed. It uploads the file okay and then I get to the second step where I enter the description etc. I can enter all the fields okay but down the bottom it says my description isn’t long enough. It is ~80 lines long so I suspect that is not a valid message.

When I press save for later or preview nothing happens but when I hover over those buttons I see an exception displayed:
com.vaadin.event.ListenerMethod$MethodException: Invocation of method buttonClick in com.vaadin.directory.ui.views.authoring.AuthoringView$5 failed.
at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:530)
at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:164)
at com.vaadin.ui.AbstractComponent.fireEvent(AbstractComponent.java:1219)
at com.vaadin.ui.Button.fireClick(Button.java:567)
at com.vaadin.ui.Button.changeVariables(Button.java:223)
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.changeVariables(AbstractCommunicationManager.java:1460)
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariableBurst(AbstractCommunicationManager.java:1404)
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariables(AbstractCommunicationManager.java:1329)
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.doHandleUidlRequest(AbstractCommunicationManager.java:761)
at com.vaadin.terminal.gwt.server.PortletCommunicationManager.handleUidlRequest(PortletCommunicationManager.java:247)

Thanks for your help

The stack trace no longer appears but I still get the following message: “Please provide a longer description to be able to publish”
preview and save-for-later buttons appear to do nothing, neither does submit. Cancel seems to work, which doesn’t really help.
What description does this refer to? There is a description on the form and I have a lot of lines entered there. I wondered if it was looking for the readme.txt file, I have a readme.html, so I added a readme.txt file but that did not help.

So at this point I cannot upload my add-on.
Please help

Hi Roger,

there seems to be an embarrassing bug in the Directory. The error message you described is presented also if the description is
too long
(the max length seems to be limited to 8192 characters).

Sorry for the confusing error message and we will surely fix this, but before this fix you should be able to publish your add-on using a shorter description. Please let us know if you still encounter any issues.

Best regards,

Thanks for the reply Teemu.
I’ve experimented with different lengths, currently my description is 3183 long. But I still see the same message.
To be clear: I started from scratch with a new upload and pasted the description in from gedit, and I’m getting the number of bytes from gedit’s statistics info (gives words, bytes etc).

Sounds strange, we’ll have to look into this. I would suggest you to initially add just one descriptive sentence to the description field (and type it by hand just in case the copy-paste would introduce something weird behaviour). Hopefully this would allow you to publish the add-on and then you can update the description afterwards.

Yes, that worked. The problem seemed to be triggered by bullet characters in the description. I retyped it without those and the problem went away.
Thanks for the help