Trying to sort out my Maven+Eclipse configuration

I’m working on a desktop application to create a decentralized P2P microblogging platform, and I’ve decided to use an embedded Jetty server, together with Vaadin, for the user interface. I’m using Eclipse and Maven.

I’ve got Vaadin up and running, it was surprisingly painless. I didn’t use the Eclipse Plugin because I got the impression that with it you need to be creating a project from scratch, which was not the case for me.

Anyway, here is my current setup, all files are to be served from a single .jar file (which I’ll create using “mvn assembly:assembly”), I believe my Jetty launcher should achieve this:

pom.xml :

Jetty launcher:

Vaadin Application:

web.xml :

My problem now is that I need to install the IcePush plugin, but I’m unable to do-so with my current setup. I’ve added icepush and icepush-gwt dependencies to my pom.xml, and I tried adding the IcePush component to my Application object, but when I did I got this error in my browser:

I assume the problem is that my current setup doesn’t know that it needs to recompile my widgetset, but I have no idea how to modify it such that it does.

I would greatly appreciate any advice, especially if it comes in the form of a git patch file for my current source code :slight_smile:

edit: I think I’ve made some progress by following these instructions:

I ran: “mvn -DskipTests=true vaadin:update-widgetset install” and it appeared to go well, this was the output:

However, now I’m getting this error and my app won’t load at all:

INFO: Requested resource [VAADIN/widgetsets/tahrir.richui.widgetset.TahrirWidgetSet/tahrir.richui.widgetset.TahrirWidgetSet.nocache.js]
not found from filesystem or through class loader. Add widgetset and/or theme JAR to your classpath or add files to WebContent/VAADIN folder.