Trying to get Vaadin 7.4.3 gzipped with Jetty

Running under Jetty 9.3.0.m2

Have this in web.xml

GzipFilter org.eclipse.jetty.servlets.GzipFilter mimeTypes text/html,text/plain,text/xml,application/xhtml+xml,text/css,application/javascript,image/svg+xml,application/json GzipFilter /*

I run up my app just fine, no complaints. But nothing is gzipped (using chrome, network inspector)

Is there something else I need to do to get things gzipped?


With a quick look your configuration looks just fine. Are you sure it is not working? Sometimes chromes network inspector is bit hard to follow. You could re-check the result in Incognito mode or with Firefox.


Tried it with FF/firebug. Same. Its all very mysterious.

I even knocked out any Vaadin in web.xml, so its just vanilla jetty.

Even plopped it on my VPS, stuck a big JS file up there.


That sure is just jetty configuration issue, has nothing to do with Vaadin. Have you checked if the log gives any hints? You could also try enabling the servlet filter with servlet 3 style annotation, might be less prone for typos. Here is
one example
of such, but uses ehcache version of gzip filter though.


Ok, success. Told it to use the mortbay version. That’s that.

org.mortbay.jetty jetty-util 6.1.26

No idea why, life’s too short. Just a sign post to others if they crazily can’t get latest gzip to work for them.