TouchKit install problem.


I’m trying a simple app with Vaadin TouchKit ( Vaadin 7 + Kepler + Tomcat 7).

First with dependencies via Ivy and now copying the vaadin-touchkit-agpl-4.0.0.alpha2.jar to WebContent/WEB-INF/lib folder.

No error at the widgetset compilation and in both cases I have this error :

INFO: Requested resource
[/VAADIN/widgetsets/com.example.teste8.widgetset.Teste8Widgetset/undefined.cache.js] not found from filesystem or through class loader. Add widgetset and/or theme JAR to your classpath or add files to WebContent/VAADIN folder.

Several hours and nothing.

Thanks in advance

The error is about your project widget set, which is either not compiled or deployer properly for some reason. The problem is probably unrelated to TouchKit. Perhaps you have changed some paths or something. There’s some
basic troubleshooting instructions in the book
(it doesn’t seem to mention @WebServlet deployment where the widget set should be defined in the @VaadinServletConfiguration annotation of the servlet, not in web.xml).

If the compiled project widget set seems to be in place, there might be something odd with Tomcat. Stop the integrated Tomcat, clear its caches by right-clicking the server and selecting Clean as well as Clean Tomcat Work Directory, and restart it.

You can also check the “Verbose compilation output” in the Vaadin section of the project settings.


After clear Tomcat’s cache and work directory the error still there.

Can’t see any error at console or error log…

The compilation process seems normaly ( wsetcompiler.txt ).

I have no references to be shure that the widgetset folder is ok ( ee.jpg ).

After replicate all the work environment with an Indigo version, the problem still there.

Thank you for your time
13394.txt (28.7 KB)

Same error ( maven.jpg ) if I use the “Maven way” as in this demo

And the same error at a new project after added Vaadin Charts ( without TouchKit ).

As you said “The error is about your project widget set, which is either not compiled or deployer properly for some reason”.

For any reason the widget set compilation / deployment in my environment is not ok.

But after several hours I can’t n know why.


I can’t see any obvious problem in your teste9 screenshot, so it’s hard to say what the problem could be. Well, earlier you wrote that the error was about “Teste8Widgetset” missing, so this is apparently a new project… I hope that you haven’t forgotten to test them with correct names or something, such mistakes occur easily…

In your Maven project screenshot, it doesn’t show that you have compiled the widget set, I hope you didn’t forget it. In a Maven project, you can do that with “Run As → Maven install”.

Note that the TouchKit archetype uses DefaultWidgetset for the FallbackUI, but the vaadin-client-compiled which contains it is not depended in the pom.xml, so loading the app with for example Firefox results in the DefaultWidgetset being missing. Well, that’s a bit different problem than what you are experiencing there.

Solved by using ivy dependence as specified at “The Book of Vaadin” ( ) instead as it is at download page →

Version and parameter ( conf=“default->default” ) are different.