TouchKit and portlet


I have a problem integrating touchkit into a portlet 1.0 in Liferay 6.1:
I have compiled the widgetset for my portlet and declared in porlet.xml.

Everything works, but I have to wait a long time before the portlet starts and the debug console says:

I found this post that is very similar:

and I tried com.liferay.portal.servlet.filters.cache.CacheFilter=false… nothing changes.

Thanks for your help.



To me it looks like the base theme is not properly loaded. Does normal vaadin application start?


Yes the application starts.

I found a way to make the portlet start normally, without errors.
But I have to remove the base theme from liferay:

Why base theme causes problems? How can I fix this?


Without further inspection it is impossible to say. Can only guess you have version mismatch or something.



thank you for your help.

My vaadin version is 6.7.9 in liferay and the same in my portlet,

theme is also 6.7.9… I think it is not a version mismatch problem.

I have tried to compile the widgetset in the portal, with the vaadin control pannel and I have the same behavior.

Do you need some other informations?

Any help would be very appreciated!



I know that if the debug dialog keeps saying “Assuming CSS loading is not complete, postponing render phase.” it usually means theme is not correctly loaded. The detection is made upon a fact whether the “loading indicator” has a proper height (!=0). I remember one case when the “target div” was invisible for some reason and thus the progress indicator didn’t have a proper height. To debug this further I’d need to access your server with modern browser like Safari or Chrome (or teach you to debug such a case).

If you want to get quickly forward, I’d suggest to
go for Pro
and request help via our ticketing system. We have a small army of Vaadin experts who can help you to get further.


Hi matti,

I really thank you for the help!

I crated a new portlet 1.0 with a custom widgetset compiled with the touchkit;
the portlet just shows “Hello Vaadin user” and there is no theme, so the default one is used.

I deployed the portlet in a fresh liferay 6.1 installation where I only changed the vaadin version to 6.7.9 (the same as the portlet).

If I call directly the servlet at http://localhost:8080/VaadinTouchkitPortlet/VaadintouchkitportletApplicationServlet?debug everything is ok but if I put the portlet into a page, I have the error.

I attach the war of this portlet… it should be easier to debug, I hope.

12516.war (5.04 MB)

Finally I found how to solve it:

there is a css line in base/styles.css

.v-view {

	position: relative;

that needs to be overridden in a custom theme.
I changed the ‘position : relative’ with ‘position : inherit’ and everything works fine.