Theme not loading in portlet

Hi, everyone.

I’m having a problem with my theme in a portlet that I developed.
We are migrating to Liferay 6.2.3 GA4, from LR 6.2.1 GA2. In LR GA2 works smoothly, but when I run the portlet in GA4, It loads incompletely.

I attached an image showing how it is on screen. Left is from Firefox, right from Google Chrome.

Are there possibly changes in LR GA4 which override what you have specified in your theme?

Hi, Artur.

I downloaded the bundle provided in the liferay site and made all the integration with vaadin 7.5, explained here :

Made the same configuration that I did in the previous version of Liferay in the new one.

I just noticed that this line was showing in the console when I run the portlet:

2015-07-13T17:17:35.696+0000|Informações: 17:17:35,695 WARN [http-thread-pool-8080(3)]

{code=“404”, msg=“”, uri=/html/VAADIN/themes/liferay/styles.css}

The strange thing is that I don’t set anywhere a theme called “liferay”. This only shows on Liferay GA4. As I said, on Liferay GA2 everything works fine.
I just don’t know where it changes the theme to the liferay theme.

If I remember correctly, the “liferay” theme is used by default unless you change it by setting a “vaadin.theme” property in Anyhow, the liferay theme should be available at /html/VAADIN/themes/liferay if you have extracted all themes from vaadin-themes.jar into that folder.