STS Roo Vaadin

I’ve worked with Vaadin in Eclipse Indigo.
It’s okay but after installing Vaadinin Eclipse Indigo we have to add manually, in direction ‘eclipse-jee-indigo-win32-> configuration ->com.vaadin.integration.eclipse->download , folders( ‘gwt-dependencies’, ‘gwt-dev’, ‘gwt-user’) .

I worked with STS Roo and can do: Spring Security, Email notification, Internationalization, Socialization and so on.

I wanted to use Vaadin with STS Roo because I like Vaadin more.

I did:
-Setup STS roo
-Did Vaadin plugin in STS Roo(didn’t add anything like I did in Eclipse Indigo).
-Created new Spring Roo Project
-Created pakage
Installed Vaadin plugins for STS Roo

roo> pgp trust --keyId 0xBF0451C0
roo> download accept terms of use
roo> addon install bundle --bundleSymbolicName com.vaadin.spring.roo.addon

Did next following the manual:

roo> persistence setup --provider ECLIPSELINK --database HYPERSONIC_IN_MEMORY

entity --class ~.domain.RapidUser --testAutomatically
field string --fieldName username --notNull --sizeMin 2
field string --fieldName password --notNull --sizeMin 4
field boolean --fieldName admin --primitive

entity --class ~.domain.Project --testAutomatically
field string --fieldName name --notNull --sizeMin 2 --sizeMax 255
field boolean --fieldName enabled --primitive

entity --class ~.domain.WorkEntry --testAutomatically
field string --fieldName comment --sizeMax 255
field reference --fieldName project --type ~.domain.Project --notNull
field reference --fieldName employee --type ~.domain.RapidUser --notNull
field date --fieldName startTime --type java.util.Date --notNull
field date --fieldName endTime --type java.util.Date --notNull

–I didn’t do roo> perform tests because it was failed like in Eclipse Indigo .

I did run as JUnit test . It was okay.
I continued:

vaadin setup --applicationPackage ~.web --baseName RapidWorkHours --themeName rapid --useJpaContainer true
vaadin generate all --package ~.web.ui --visuallyComposable true

I run as ‘Run on server’ and then I clicked ‘save’ button to save data. I had the message:

SEVERE: Terminal error:
at com.vaadin.event.ListenerMethod.receiveEvent(

I continued to install add-ons(Though Calendar worked on UI)

roo> vaadin addon install --artifactId vaadin-calendar
roo> vaadin widgetset create

I had the 2nd exception:
Cannot run program “mvn.bat” ( in directory… of my project)

I like Vaadin docs and I’ve never had the problem with it like with Spring ones.
I searched Vaadin Forum . Vaadin with STS Roo has some problems with ad-dons.
Please give me advice…

Just based on this information, I’m afraid it is not really possible even to guess what might have gone wrong here. I assume you are using the tcServer bundled with STS, but is the project configuration OK in STS? Is everything refreshed in Eclipse? All operations performed via the Roo shell in Eclipse?

What versions of each system (STS, Roo, tcServer, Vaadin addon, …) are you using? What do you see on the browser? Any other information you can provide?

You must have the Maven executable or script on your path - this is also required by a number of standard (non-Vaadin) Roo commands such as “perform package”.

The default installation package of STS includes a suitable version of Maven but might not add it on your path.

To Henry Sara.
Thanks for replay.
Today I’ve checked everything again . I had the same result.

I did the same in Linux(Ubuntu 10.04). It was the same result.
When I pressed button ‘Save’ we had exception:

com.vaadin.Application terminalError

SEVERE: Terminal error:
at com.vaadin.event.ListenerMethod.receiveEvent(

WEB server showed: “http://localhost:11604/Rapid/#Rapid%20User/new
I used tcServer .
Version of ‘springsource-tool-suite-2.7.0’(maven-2.2.1.RELEASE, spring-roo-1.1.4.RELEASE, sts-2.7.0.RELEASE, vfabric-tc-server-developer-2.5.0.RELEASE) the newest ones.
Vaadin I installed from help->Install new software->add ‘h’ and chose ‘Vaadin’ it was installed by itself .
I think it’s the problem of setup of DB because ‘cancel’ button works( with BeanItemContainer ).
I changed DB Hibernate - Derby . It didn’t help.

Thanks again

Apparently I missed something last time.

Which kind of entity are you trying to save (of the three types you created) when you get the error?
The entities are quite simple, but does it help if you remove some fields from the entities, or e.g. change the primitive fields to non-primitive ones?
Is there a longer stack trace available (especially the “caused by” parts might be of interest here)?

Now I didn’t use primitives in both entities at all . It works okay.

'Save", '‘Cancel’ buttons and ‘Delete’ reference works correctly.

I’ll continue manual later.
What’s the problem with primitives? This exception is for all primitives(boolean, numbres…)
Thanks a lot.

Why I suspected primitives is because support for them in the Vaadin addon was added very recently, and because there was nothing else special about your Roo script.
If you are using the latest version of the add-on, please
file a bug report
with compact instructions on how to reproduce this.