[SOLVED]Syntax error in .cache.html files

Hi all,
I’m facing a strange problem:
When lauch a simple application i have nothing on screen, but messages in browsers console (IE8 & FF3.5). The error is not the same, but maybe it’s normal due to different browser handling. Here is what i have

Error : syntax error
Fichier Source :
Line : 1304, row : 1
Source Code:

Message : Syntax error
Line: 1287
Caracter : 157
Code : 0

In all browser i have the waiting icon on the top left and with ?debug i have the console that says:
Drag=move, shift-drag=resize, doubleclick=min/max.Use debug=quiet to log only to browser console.
Vaadin application servlet version: 6.1.1
Widget set is built on version: 6.1.1
Application version: NONVERSIONED
inserting load indicator
Making UIDL Request with params: init
Server visit took 55ms

Init() method content

Window mainWindow =
new Window(“Myproject Application”);
Label label = new Label(“Hello Vaadin user”);

I really don’t know what happen but maybe some could help me ? Maybe this could help, the tomcat is 5.5 and embedded into another application (i think resources are well delivered cause i got the favicon well displayed).


Those files are produced by the GWT compiler. Somehow you ended up with a corrupted file.

  • Try to re-deploy.
  • Clear browser caches
  • If you have compiled the widgetset yourself, try to recompile it.

When debugging problems in widgetsets you have compiled yourself you generally want to add the parameter -style DETAILED in the compile command. This results in GWT creating readable javascript, and the error messages can actually be of some help for tracking down the problem.

a ticket
for this be the default for widgetsets created using the plugin.

thanks for you answer.

  • I have redeploy everything, in fact everything is re-deployed each time i restart my app cause the embedded tomcat is built (configuration, context, mappins…) programaticaly at startup.
  • Done but no effects even on FF & IE
  • Compiles widgetset, oh oh ! no ! that’s only my first day with vaadin :*) all that i’ve done is download the vaadin-windows-6.1.1.zip from the website and extract the webontent/VAADIN to my app, a simple cut & paste, nothing more. Maybe i should download an older version and try again ?


This sound really strange - must be a deployment problem. Using another Vaadin version would not help as the precompiled html files distributed with 6.1.1 are tested by lots of people and work fine.

Did you try run demos locally (running start.sh or start.bat after unzipping the package)? Did they work ok?

Try to stop tomcat, clean any deployed files, clean browser caches, restart tomcat and redeploy.

I’ve tried many examples of the sampler and everything works fine
I’ve also tried on a fresh virtual machine to avoid cache problem, but unsucessfull.
I’ve tried inside and outside Eclipse, same.

I’ve compared what FF get when going to somethig like
and the file in the demo zip file and they are the same. I think that if it was a deployement problem, they would be different.
The only (un)significant message i got in the console is “Assuming CSS loading is not complete, postponing render phase. (.v-loading-indicator height == 0)” but not always, generally at first start

i’m lost:(

Can you give us a link to your application?

I’ll try to give an access tomorrow, not easy to do it today.

I’ve found something strange too, maybe there is no link between with my problem?
i join the sample app with something like:

on application loading there a request to

But i have nothing that can answer this request.
If i’m not wrong, but really not sure, UIDL seems to be needed when using your home made widgets, what is not my case.
i’m wrong, seems to be used all the time. So maybe my problems comes from that ?

I found the reason reading this thread in the forum:

Context appCtx = this.embedded.createContext(“/ConsoleV2”, contextPath);

Wrapper wrapper = appCtx.createWrapper();
wrapper.addInitParameter(“application”, “com.csis.JDexSphere.consoleV2.Console”);

appCtx.addServletMapping(“/ConsoleV2”, “ConsoleV2” );

appCtx.addServletMapping(“/VAADIN/*”, “ConsoleV2” );

here is the correct code

appCtx.addServletMapping(“/ConsoleV2/*”, “ConsoleV2” );

Thanks all for your answers

So the problem was that browser never even read the widgetset files, but tried to interpret some error page HTML as javascript?

As the answer is not a widgetset content (a simple 404 tomcat error page), the javascript try to access missing objects, resulting an error. Thats what i suppose cause i can’t read the javascript compressed format :*), and see why i got this error

It would be great to be able to somehow recognize this situation and give a better error message. Created ticket for this