Setting heartbeatInterval has no effect

I set vaadin.servlet.heartbeatInterval in and during startup it shows:
c.v.s.b.i.VaadinServletConfiguration - Set servlet init parameter [heartbeatInterval]
= [9999]

But it has no effect. The heartbeat is still called after the default time. Is there a working way to disable heartbeat? I think heartbeat is the cause of my problem with random lost sessions


I guess you are using the vaadin-spring-boot add-on for to even be an option, but I’m afraid I’m not personally familiar with the intricacies of that one. However, there are some other configuration options listed in in case those might work for you. And the whole article is actually a very good read for understanding the various options you can have configuring the application lifecycle, and why some of the options might be counterproductive in combination or cause each other to misbehave.