Running on WildFly within Eclipse, or debugging in Jetty

First Issue:
I downloaded and installed the Project Base starter project, installed it, and it runs fine with Jetty. But when I try to debug it, the source code will not display. I get a tab in the debug perspective that is titled “MainView.() line: 17” and in the source pane, it says “Source not found”. I get the option to Edit Source lookup path, and when I select “project” the source code flashes for about one second, and then disappears. How can I fix that?

Second issue:
So I tried to run this in Eclipse using Wildfly, hoping that if I can run there, that I can easily degug using Wildfly. I deployed the app into the Wildfly app server, then started my server, and when I enter the URL in my Chrome browser, I just get a 404 - Not Found. Any suggestions on what I need to do to deploy to Wildfly and running/debugging within Eclipse?

Thank you for any help you can provide

Steve J.

I solved the wildfly 404 Not Found error by creating a WEB-INF folder under src/main/webapp. In the WEB-INF folder, I created a new file named jboss-web.xml. The contents of that file are:

<?xml version="1.0" encoding="UTF-8"?>

Setting the context-root seems to be the solution.