RE: Add-on MaskedTextField

Well, that’s strange, it should work nearly automatically, perhaps you have some plugin installation issue, or some project setting issue.
When I tried the tutorials, I created a Vaadin project, and it made automatically a number of folders and files.
I then added a couple of add-ons (jars) in WebContent/WEB-INF/lib, and upon refresh of this folder (important!), it proposed automatically to recompile the widgetset. If it fails to do propose, I can use the button, to be sure.
You have to refresh the Vaadin application page in the browser with the ?restartApplication parameter in the URL.
Note that in the folder where your class extending Application is, there is a widgetset folder created by Vaadin, with a file like YourApplicationNamewidgetset.gwt.xml
You must have only one of such file in your application.

I entered the options and could have build, look what appeared on the console:

Compiling widgetset com.intecnologia.igestor.view.vaadin.consertaMais.application.widgetset.IgestorWidgetset
Updating GWT module description file …
10/27/2011 10:47:28 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
INFO: Widgetsets found from classpath:
com.vaadin.terminal.gwt.DefaultWidgetSet in
com.vaadin.maskedtextfield.widgetset.MaskedTextFieldWidgetset in
com.intecnologia.igestor.view.vaadin.consertaMais.application.widgetset.IgestorWidgetset in file: / / C / development / Java / Software / Eclipse / iGestor / JavaSource

10/27/2011 10:47:28 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
INFO: Search took 15ms
Starting GWT compiler
10/27/2011 10:47:52 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getPaintablesHavingWidgetAnnotation
INFO: Searching for paintable …
10/27/2011 10:47:53 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getPaintablesHavingWidgetAnnotation
INFO: Search took 1609ms
Widgetset compilation completed

Yet still not working;

Hey, the start of the thread has disappeared! What happened?

Yet still not working;
In what way? Not displaying? Error messages? Other?

When I run the application which was to have a field MaskedTextField, such that:

Does not contain Widgetset Implementation for com.vaadin.ui.MaskedTextField. Check @ ITS ClientWidget mapping, widgetsets GWT module description file and re-compile your widgetset. In case you have downloaded the add-on package vaadin, You Might want to refer to add-on instructions. Unrendered UIDL:

  • Unrendered UIDL

I do not understand, have tried everything.