@Push "push is not available"


following lines are working fine, if I use vaadin in Eclipse:
PushConfiguration pushConnection = UI.getCurrent().getPushConfiguration();

If I create a new Version for our customer and upload it on our live Server I receive the message “push is not available” while setting the push mode (pushConnection.setPushMode).

My ivy.xml looks like:

And I have the vaadin push, atmosphare jar also in my Build Path in Eclipse. So in Eclipse everything is working while using the Push.

I also tried to put the jars into the Webinf/jar folder on the live server, but still the same error.

Could anybody help?
Thanks Dennis


I remember for Tomcat deplyments, we have to enable Async operation using the following entry in web.xml
In order to activate PUSH
I suppose you need to configure your webserver with something similar.

Thanks for your answer Aziz. I found the problem. On our live system the atmosphere-runtime and the vaadin-slf4j-jdk jar file was not part of our class path.