Push mode not working on 7.2.5 and Glassfish?

it seems that the push mode is not working on Vaadin 7.2.5 when using Glassfish, not dependent on the version, I tried 3.1 and 4.0.
Without push mode the application is working fine, but when I enable the push mode every click on a button results in the message “Communication Problem, take note on any unsaved date…” and the debug window in the browser returns the following error: “Server response didn’t contain a sync id. Please verify that the server is up-to-date and that the response data has not been modified in transmission.”. However the console in Eclipse does not display an error message.

The two glassfish testserver have both enabled comet and websocket, and in the 3.1 version the grizzly-websocket jar has been replaced, like described in

Currentley this is not a big problem because the application is in development, but in 3 month it should run on our production glassfish server and then push should work again.

Is this an error by us, or is there a bug in the push implementation of 7.2.5?


Hi Florian, could you clarify whether you have encountered this problem in Vaadin 7.2.5 only or in earlier 7.2 (or 7.1!) versions as well?

sorry for the late reply but last week I had holidays and therefore I didn´t check the posts. Yesterday in the evening I tried to reproduce the error. I created two applications one with 7.1 and one with 7.2 and then I enabled the push mode on both. With the default “application” (the click me example) I was not able to reproduce the error, it wirked fine. As a second test I added the table-export addon compiled the widget and again everything works. Today probably I will try to add the google-map addon to the two test applications and I will try again. The problem occured in a rather simple application where we created a person generator and an IP-Address location finder.
But the main difference to the two test application is, that we changed later form manual dependency management to ivy. Probably this might be the reason for the problem. As fast as I know more I will make a new post.

Thank you,

I have the same problem with Glassfish and Push enabled. I’m getting this error on Chrome v37, Firefox v32, IE v11.

I’m able to open the application coorectly only with IE8.

Glassfish is a fresh installation running on a Solaris SPARC with JDK 1.6.0_45 (64b)

On the other hand I have the same application (same WAR file ) deployed on a Glassfish running on a Linux (Centos) server and on a Windows Server 2088 R2 Enterprise and everything is working FINE.

So it seems like the issue is the machine being Glassfish running on a Solaris SPARC either the Glassfish version for Solaris or Solaris itself.

I cannot figure out what the problem coud be and really how to solve it. I’m stuck here.

Please help,