Problem with Push switching from vaadin-spring-boot 1.0.2 to 1.1.1


I have a Spring-Boot-Vaadin project with Push enabled. Everything works fine with spring-platform-bom Athens-Release, vaadin-spring-boot 1.0.2 and Vaadin 7.4.8. If I try to update to spring-platform-bom Athens-SR1, vaadin-spring-boot 1.1.1 and Vaadin 7.7.6. I get the following error message: “Atmosphere could not be loaded. When using push with Vaadin, the
Atmosphere framework must be present on the classpath.If using a dependency management system, please add a dependency to vaadin-push. If managing dependencies manually, please make sure Atmosphere
2.2.9.vaadin2 is included on the classpath. Will fall back to using PushMode.DISABLED.”
Because Atmosphere 2.2.9.vaadin2 is on the classpth, this seems to be a class loading problem, perhaps in context of spring boot. Any ideas?


Here is a little test project showing the problem:

After some testing I can say that it has something to do with a difference between
Vaadin 7.7.x
and e.g.
Vaadin 7.6.x
or rather
Atmosphere Framework 2.2.7.vaadin1
Atmosphere 2.2.9.vaadin2.

Hi Michael,
just tried your test project and it works for me without errors.
Maybe a corrupted dependency? Have you tried to unpack the fat jar and to verify the atmosphere library ?

Thanks for looking. Strange - you actually served to the “start view” without errors? I use the spring tool suite, not the jar itself. I’ll have a look at it this this evening again.

Yes, the start view is served correctly.
I run the project with
mvn spring:run
and even with
java -jar target/xxxxx.jar

Thank you very much. I cleaned my .m2/repository and fetched all dependencies again and now it is running…