Problem with "Hello Vaadin user" default text

I am new with eclipse and vaadin, and i have a problem that i can’t seem to get solved. Everything seem to work properly and i can code my application with eclipse, but when i run it, it only gives me a label text “Hello Vaadin user” as output. It doesn’t matter what i put into my java code, its always that same text. Is it possible that its runnig some default helloworld project from somewhere?. Here is my code so you can see its quite simple;

import com.vaadin.ui.*;

public class testi1 extends com.vaadin.Application {

public void init() {
	Label la = new Label("Moe maailma");
	Window main = new Window("Otsikko");


So it should say in the output “Moe maailma” but instead it says always “Hello Vaadin user”. What is wrong, can someone tell?

It’s showing “Moe maailma” to me.

Unfortunatelly, I don’t know what might be happening.

Vaadin’s state is preserved on the server side, which means, that if you refresh your browser, your application will be in the same state thus any modifications will not be seen. Try adding the “?restartApplication” to the end of your URL (so your URL will be something like http://localhost/helloworldapp/?restartApplication), it will force Vaadin to start a new session with the user and you should now be able to see any changes you’ve made.

I was Jay Man user previously and i’ve lost my passwords for my mail account so i couln’tget my passwords here, so i created new account. That’s wy i’mhere with different username than Jay Age :slight_smile: So back in business.

I tried that “?restartApplication” but t did not help. Problem s always there, even if i start a new project. If i try to debug, it doesn’t go into my code at all. That’s why i think there is somekind of setting somewhere that tells the server to run some default helloworld project. I run testi1 project by right clicking testi1 project in Eclipses project explorer and select run as server, so i don’t think there is any problem. To be clear i made same project with different label text and the output is still the same “Hello Vaadin user”. Here is the code and output of eclipse console.

import com.vaadin.ui.*;
public class Rojektii extends com.vaadin.Application {

public void init() {
	Label la = new Label("Here is some text");
	Window main = new Window("Window text is here");


13.1.2010 11:26:55 org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]
{Server/Service/Engine/Host/Context} Setting property ‘source’ to ‘org.eclipse.jst.jee.server:Rojektii’ did not find a matching property.
13.1.2010 11:26:55 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jre6\bin; *** ( i deleted rest of these paths ) ***
13.1.2010 11:26:55 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
13.1.2010 11:26:55 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 698 ms
13.1.2010 11:26:55 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
13.1.2010 11:26:55 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.20
13.1.2010 11:26:56 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
13.1.2010 11:26:56 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /
13.1.2010 11:26:56 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/47 config=null
13.1.2010 11:26:56 org.apache.catalina.startup.Catalina start
INFO: Server startup in 784 ms

Vaadin is running in DEBUG MODE.
Add productionMode=true to web.xml to disable debug features.
To show debug window, add ?debug to your application URL.


My guess is that you’re still running the initial application - you see “Run on server” in Eclipse does not actually run the file you clicked on the server, it only starts the server and runs the applications as configured in web.xml.

So what’s happening is probably that you have an old web.xml that is running your old application.

…actually this is sort of a wild guess, but to me it sounds like this is your problem…

So what does your web.xml say?

Best Regards,

Update: Actually, looking more closely at the output, I’m not sure that’s your problem, but checking web.xml is still my best bet.

I found the problem. It was me :slight_smile: Because i was use to do things so, that i make a new project and then i created manually new class to it with java, i did the same thing now. But i noticed that package and class was created initially and server used that java file.