Problem with "Get Started" Maven version

I’m new to Vaadin. Been trying to get the maven version of the “Get Started” tutorial to work (on OSX), but I keep getting the same error.
I would appreciate any input that anyone can provide.

Steps (from
Enter the following in terminal (on OSX): mvn -B archetype:generate -DarchetypeGroupId=com.vaadin -DarchetypeArtifactId=vaadin-archetype-application -DarchetypeVersion=7.6.7 -DgroupId=org.test -DartifactId=vaadin-app -Dversion=1.0-SNAPSHOT
cd vaadin-app
mvn package jetty:run

I keep getting the following error:
— vaadin-maven-plugin:7.6.7:compile (default-cli) @ vaadin-app —

auto discovered modules [org.test.MyAppWidgetset]

Failed to retrieve com.vaadin:vaadin-client-compiler based on project POM

Using com.vaadin:vaadin-client-compiler version 7.6.7

Error: Could not find or load main class



So I tried the same tutorial using the Vaadin 7.6.2 version and all works well; I am not encountering the same error related to the gwt compiler.
I wonder whether this is an issue with the latest 7.6.7 version or something else I am doing wrong.