Problem running Vaadin in Eclipse using Tomcat


a few Month ago, I managed to install Eclipse, Vaadin, Maven and started programming with Vaadin.

I created my Project with maven (vaadin-clean artefact), imported it into Eclipse and could run it via Run as->Run on Server. Everything fine so far.

Now I need to install Eclipse Vaadin Maven on a second PC. I downloaded Eclipse Indigo Win32 (also tried Eclipse for Java EE).
I installed the Vaadin Plugin, Maven. I looked at my PC, which Plugins are installed that I am using. (I tested a lot of other Plugins).

In the End i wanted to load my Project via ‘Check out Maven Projects from SCM’. That worked well. But I’m missing the Run on Server in the Run as Menu.

I then tried a fresh maven Project using the vaadin-clean archetype. I tried it on my PC first and
everything went as espected. Then I tried on the new PC. I created a new Project, imported it into Eclipse
and there is no Run on Server.
In the Preferences the Vaadin Entry is missing. If I select Project Facets I can convert it to faceted Form.
I tried to configure it, but that lead to other Errors.

Can someone help me, to find out, what is going wrong?


Hi Willi,

I think you need the Eclipse Web Tool Platform (WTP) installed. For Eclipse Indigo you can use this update site

Information about the Maven WTP support can be found here

Hope this helped,

Hello Christoph,

thanks for your Reply.

I had only installed the most of the WTP 3.3.2 Packages. In my
working Installation I had some Packages from older Releases.
These had been missing in my non-working Installation.
Now all WTP 3.3.2 packages are installed.

Today I tested a bit more. I created a new Test Project with Maven.
Then I imported it into the non-working Installation, and as expected,
it doesn’t work.
Then I started the working Installation, with the same Workspace.
It says, my Project Configuration isn’t up to date. I updated it,
and the Projects works.

SVN showed me which Files had been added or modified.

In .classpath the Attributes for the following entry are missing:

in .project
the buildcommands




and the following natures

have been added.

In the .settings Folder the Files

are modified and


have been added.

I then startet the non-working Installation and tried to run the test Project.
Eclipse says there is a Problem, the Project Configuration is not up-to-date.
If I ignore the Problem I can start the Project via Run on Server.

Then I Updated the Project Configuration and I still can run it via run on server.

I checked the Plugins again and found only an Update for m2e. I believe, one or
more Plugins are missing or not configured properly. But I can’t find it.


I just installed Eclipse Java EE Helios and tried to run a Fresh maven created vaadin-clean Application and it worked.

Does somebody know, what is going wrong if I use Eclipse Java EE Indigo?