Problem compiling widgetset in a vaadin/spring application


I’m trying to add a new addon to my app (popupbutton), when i compile the widgetset everything looks fine (no errors with verbose mode on), but when i’m going to run the app it seems that the popupbutton addon is not compiled.

Widgetset does not contain implementation for org.vaadin.hene.popupbutton.PopupButton. Check its @ClientWidget mapping, widgetsets GWT module description file and re-compile your widgetset. In case you have downloaded a vaadin add-on package, you might want to refer to add-on instructions. Unrendered UIDL:
org.vaadin.hene.popupbutton.PopupButton(NO CLIENT IMPLEMENTATION FOUND)
Widget set will contain implementations for following components: 
               Done. (0seconds)
   Compiling 6 permutations
      Compiling permutation 0...
      Process output
            Compiling permutation 1...
      Compiling permutation 2...
            Compiling permutation 3...
      Compiling permutation 4...
            Compiling permutation 5...
   Compile of permutations succeeded
   Linking into WebContent/VAADIN/widgetsets
      Link succeeded
   Compilation succeeded -- 174,528s

Popupbutton isn’t the problem because i’ve tried creating a new project without spring and it works fine.

Any idea??


Roo? Perhaps it’s the problem described in

When compiling a widgetset with the Plug-in for Roo, the widgetset is placed in ${}/${}/VAADIN/widgetsets which is not on the default deployment path. To make the compiled widgetset work, the user has to add target/…/VAADIN to the server deployment assembly as /VAADIN.

No, it isn’t Roo. I’ve added a screenshot with the problem.

Other addons like easyupload, pagedtable… work fine, but i think that they don’t have a widgetset.

I’m still having this problem. I’ve tried compiling the widgetset with an ant script but the problem persist.

I’m using spring + hibernate libs.

Any ideas?